Bug 1191245 - Main repos do not have appstream metadata
Main repos do not have appstream metadata
Status: RESOLVED DUPLICATE of bug 1192278
: 1184335 (view as bug list)
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Other
Leap 15.3
Other Other
: P5 - None : Critical with 5 votes (vote)
: ---
Assigned To: Lubos Kocman
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-10-02 12:36 UTC by Fabian Vogt
Modified: 2021-11-03 16:09 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2021-10-02 12:36:42 UTC
Basically the same as bug 1172416, just for 15.3.

Even after a forced zypper refresh, the only appstream metainfo is from the non-oss repo, containing just Steam and Opera.

The reason is that the main repo(s) do not have any appdata archives, e.g.: https://download.opensuse.org/distribution/leap/15.3/repo/oss/repodata/?P=*appdata*

Compared to TW: https://download.opensuse.org/tumbleweed/repo/oss/repodata/?P=*appdata*

This makes applications which work based on those files like GNOME Software and Plasma Discover pretty useless.
Comment 1 Max Lin 2021-10-04 04:46:30 UTC
If this is about https://build.opensuse.org/package/rdiff/openSUSE:Leap:15.2/appstream-glib?linkrev=base&rev=24 , after CtLG, appstream-glib switch to SLE's version from SP2:GA which doesn't have that patch..
Comment 2 Fabian Vogt 2021-10-04 11:57:43 UTC
Looks like it:

[ 5049s] May-24 14:11:05 <1> : [I] Called /usr/bin/openSUSE-appstream-process /usr/src/packages/KIWIROOT/main/openSUSE-Leap-15.3-x86_64-aarch64-ppc64le-s390x-Build160.3-Media1 /usr/src/packages/KIWIROOT/main/openSUSE-Leap-15.3-x86_64-aarch64-ppc64le-s390x-Build160.3-Media1/repodata exit status: <139> output: Scanning packages...

I suppose the fix needs to be submitted to SLE?

It appears like a "15.3 respin" is in progress. If that's true, this needs to be included.
Comment 3 Max Lin 2021-10-12 08:27:38 UTC
(In reply to Fabian Vogt from comment #2)
> Looks like it:
> 
> [ 5049s] May-24 14:11:05 <1> : [I] Called
> /usr/bin/openSUSE-appstream-process
> /usr/src/packages/KIWIROOT/main/openSUSE-Leap-15.3-x86_64-aarch64-ppc64le-
> s390x-Build160.3-Media1
> /usr/src/packages/KIWIROOT/main/openSUSE-Leap-15.3-x86_64-aarch64-ppc64le-
> s390x-Build160.3-Media1/repodata exit status: <139> output: Scanning
> packages...
> 
> I suppose the fix needs to be submitted to SLE?

Yes, someone or maintainer need to submit it to SLE.

> 
> It appears like a "15.3 respin" is in progress. If that's true, this needs
> to be included.

I forked appstream-glib+patch to 15.4 and 15.3 Respin.
Comment 4 Fabian Vogt 2021-10-14 09:15:23 UTC
A fixed version of appstream-glib is in SUSE:SLE-15-SP4:GA meanwhile.
Comment 5 Fabian Vogt 2021-10-14 10:01:15 UTC
*** Bug 1184335 has been marked as a duplicate of this bug. ***
Comment 6 Lubos Kocman 2021-11-03 16:09:43 UTC
Fixed as part of Bug 1192278

*** This bug has been marked as a duplicate of bug 1192278 ***