Bug 1189853 - [Build 20210825] accountsservice: not able to create home directory
[Build 20210825] accountsservice: not able to create home directory
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dominique Leuenberger
E-mail List
https://openqa.opensuse.org/tests/188...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-08-26 15:07 UTC by Dominique Leuenberger
Modified: 2021-10-26 06:45 UTC (History)
0 users

See Also:
Found By: openQA
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2021-08-26 15:07:02 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-desktopapps-gnome@64bit fails in
[change_password](https://openqa.opensuse.org/tests/1887264/modules/change_password/steps/18)

accountssservice has been hardened by harden_accounts-daemon.service.patch

but protecting home directories is not a good idea for a service creating home directories.


## Test suite description
Maintainer: qkzhu@suse.com
See https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3558
and
poo#23884


## Reproducible

Fails since (at least) Build [20210825](https://openqa.opensuse.org/tests/1887264) (current job)


## Expected result

Last good: [20210824](https://openqa.opensuse.org/tests/1885645) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=desktopapps-gnome&version=Tumbleweed)
Comment 1 OBSbugzilla Bot 2021-08-26 15:40:05 UTC
This is an autogenerated message for OBS integration:
This bug (1189853) was mentioned in
https://build.opensuse.org/request/show/914414 Factory / accountsservice
Comment 2 Dominique Leuenberger 2021-09-02 08:17:45 UTC
(In reply to OBSbugzilla Bot from comment #1)
> This is an autogenerated message for OBS integration:
> This bug (1189853) was mentioned in
> https://build.opensuse.org/request/show/914414 Factory / accountsservice

Tests on openQA pass since this fix