Bug 1186786 - lxd exec don't work
lxd exec don't work
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Other
Leap 15.3
x86-64 openSUSE Leap 15.2
: P5 - None : Major (vote)
: Leap 15.3
Assigned To: Aleksa Sarai
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-06-03 05:39 UTC by Dmitry Markov
Modified: 2022-05-05 06:40 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Markov 2021-06-03 05:39:12 UTC
after upgrade leap from 15.2 to 15.3 lxc exec broken

> lxc launch images:ANYTHING test
> lxc exec test /bin/WHATEWER
Error: Failed to retrieve PID of executing child process

> rpm -qa | grep lxd
lxd-bash-completion-4.13-bp153.2.10.noarch
lxd-4.13-bp153.2.10.x86_64

P.S.: sorry for my english
Comment 1 Dmitry Markov 2021-06-03 06:57:53 UTC
in lxd vers 4.14 from Virtualization:containers repo problem repeats
Comment 2 Dmitry Markov 2021-06-10 05:49:08 UTC
thred about this problem on linuxcontainers.org forum

https://discuss.linuxcontainers.org/t/lxc-exec-results-in-error-failed-to-retrieve-pid-of-executing-child-process/11285
Comment 3 Dmitry Markov 2021-06-25 09:40:37 UTC
fixed in https://github.com/lxc/lxd/pull/8908

but not yet in the repositories
Comment 4 Aleksa Sarai 2021-06-25 09:57:55 UTC
I'll backport this to our packages. It'll take a little bit to make it into Leap but it'll be in Virtualization soon.
Comment 5 OBSbugzilla Bot 2021-06-25 14:10:10 UTC
This is an autogenerated message for OBS integration:
This bug (1186786) was mentioned in
https://build.opensuse.org/request/show/902390 15.2 / lxd
https://build.opensuse.org/request/show/902391 15.3 / lxd
Comment 6 Aleksa Sarai 2021-06-26 01:49:37 UTC
Backported, accepted to Factory and submitted to Leap.
Comment 7 Aleksa Sarai 2021-06-26 01:49:58 UTC
[Mid-air collision, need a comment to close the bug.]
Comment 8 Swamp Workflow Management 2021-07-02 16:16:31 UTC
openSUSE-RU-2021:0957-1: An update that has two recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1186786,1186906
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    lxd-4.15-lp152.2.38.1
Comment 9 OBSbugzilla Bot 2021-08-02 10:30:17 UTC
This is an autogenerated message for OBS integration:
This bug (1186786) was mentioned in
https://build.opensuse.org/request/show/909717 15.3 / lxd
Comment 10 Swamp Workflow Management 2021-08-10 07:18:38 UTC
openSUSE-RU-2021:1122-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1102408,1186647,1186786,1186906,1188946
CVE References: 
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP3 (src):    lxd-4.16-bp153.3.6.1
Comment 11 OBSbugzilla Bot 2021-08-20 14:40:15 UTC
This is an autogenerated message for OBS integration:
This bug (1186786) was mentioned in
https://build.opensuse.org/request/show/913362 15.3 / lxd
Comment 12 Swamp Workflow Management 2021-08-25 19:30:33 UTC
# maintenance_jira_update_notice
openSUSE-RU-2021:1195-1: An update that has 6 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1102408,1186647,1186786,1186906,1188946,1189645
CVE References: 
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP3 (src):    lxd-4.17-bp153.3.9.1
Comment 13 OBSbugzilla Bot 2021-12-13 04:40:11 UTC
This is an autogenerated message for OBS integration:
This bug (1186786) was mentioned in
https://build.opensuse.org/request/show/940127 15.3 / lxd
Comment 14 OBSbugzilla Bot 2022-05-05 06:40:07 UTC
This is an autogenerated message for OBS integration:
This bug (1186786) was mentioned in
https://build.opensuse.org/request/show/975026 15.3 / lxd