Bug 1184348 - (CVE-2021-30004) VUL-0: CVE-2021-30004: wpa_supplicant, hostapd: forging attacks may occur because AlgorithmIdentifier parameters are mishandled in tls/pkcs1.c and tls/x509v3.c
(CVE-2021-30004)
VUL-0: CVE-2021-30004: wpa_supplicant, hostapd: forging attacks may occur bec...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/280916/
CVSSv3.1:SUSE:CVE-2021-30004:5.3:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-04-06 07:22 UTC by Robert Frohl
Modified: 2021-10-14 09:08 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2021-04-06 07:22:22 UTC
CVE-2021-30004

In wpa_supplicant and hostapd 2.9, forging attacks may occur because
AlgorithmIdentifier parameters are mishandled in tls/pkcs1.c and tls/x509v3.c.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-30004
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-30004
https://w1.fi/cgit/hostap/commit/?id=a0541334a6394f8237a4393b7372693cd7e96f15
Comment 1 Robert Frohl 2021-04-06 10:03:52 UTC
tracking as affected:
- SUSE:SLE-12:Update/wpa_supplicant
- SUSE:SLE-12-SP5:Update/wpa_supplicant
- SUSE:SLE-15:Update/wpa_supplicant

hostapd only seems to be relevant for openSUSE
Comment 2 Robert Frohl 2021-04-06 10:06:34 UTC
(In reply to Robert Frohl from comment #1)
> hostapd only seems to be relevant for openSUSE

Leap 15.2/15.3 and Tumbleweed are affected
Comment 6 OBSbugzilla Bot 2021-04-07 10:20:06 UTC
This is an autogenerated message for OBS integration:
This bug (1184348) was mentioned in
https://build.opensuse.org/request/show/883563 15.2 / hostapd
https://build.opensuse.org/request/show/883564 15.3 / hostapd
Comment 7 OBSbugzilla Bot 2021-04-07 14:20:06 UTC
This is an autogenerated message for OBS integration:
This bug (1184348) was mentioned in
https://build.opensuse.org/request/show/883614 Backports:SLE-15-SP3 / hostapd
Comment 8 Swamp Workflow Management 2021-04-09 04:17:51 UTC
openSUSE-SU-2021:0519-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1150934,1172700,1184348
CVE References: CVE-2019-16275,CVE-2020-12695,CVE-2021-30004
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    hostapd-2.9-lp152.2.3.1
Comment 10 Swamp Workflow Management 2021-04-09 19:17:57 UTC
SUSE-SU-2021:1125-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1184348
CVE References: CVE-2021-30004
JIRA References: 
Sources used:
SUSE Linux Enterprise Server 12-SP5 (src):    wpa_supplicant-2.9-23.12.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2021-04-12 13:18:30 UTC
openSUSE-SU-2021:0545-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1150934,1172700,1184348
CVE References: CVE-2019-16275,CVE-2020-12695,CVE-2021-30004
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP2 (src):    hostapd-2.9-bp152.2.3.1
Comment 12 Swamp Workflow Management 2021-04-13 16:16:25 UTC
SUSE-SU-2021:1166-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1184348
CVE References: CVE-2021-30004
JIRA References: 
Sources used:
SUSE MicroOS 5.0 (src):    wpa_supplicant-2.9-4.29.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    wpa_supplicant-2.9-4.29.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 13 Swamp Workflow Management 2021-04-16 22:15:38 UTC
openSUSE-SU-2021:0563-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1184348
CVE References: CVE-2021-30004
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    wpa_supplicant-2.9-lp152.8.12.1
Comment 15 Marcus Meissner 2021-10-14 09:08:38 UTC
done