Bug 1184252 - Focusrite Scarlett 2i2 (3rd gen) stops working in latest default kernel (5.11.11-1.1.gdbc4a02.x86_64)
Focusrite Scarlett 2i2 (3rd gen) stops working in latest default kernel (5.11...
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 15.2
x86-64 openSUSE Leap 15.2
: P3 - Medium : Normal (vote)
: Leap 15.2
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-04-01 04:49 UTC by Peter Terpstra
Modified: 2021-04-02 18:21 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Terpstra 2021-04-01 04:49:15 UTC
Dear people,
Just want to make this announcement, discovered that the latest kernel upgrade, gave me this message in /var/log/messages

2021-03-31T16:55:01.192647-07:00 chenrezi kernel: [ 200.463947] usb 1-3: USB disconnect, device number 6
2021-03-31T16:55:09.980751-07:00 chenrezi kernel: [ 209.251375] usb 1-3: new high-speed USB device number 7 using xhci_hcd
2021-03-31T16:55:10.128643-07:00 chenrezi kernel: [ 209.400167] usb 1-3: New USB device found, idVendor=1235, idProduct=8210, bcdDevice= 5.ff
2021-03-31T16:55:10.128680-07:00 chenrezi kernel: [ 209.400181] usb 1-3: New USB device strings: Mfr=1, Product=3, SerialNumber=2
2021-03-31T16:55:10.128686-07:00 chenrezi kernel: [ 209.400186] usb 1-3: Product: Scarlett 2i2 USB
2021-03-31T16:55:10.128689-07:00 chenrezi kernel: [ 209.400191] usb 1-3: Manufacturer: Focusrite
2021-03-31T16:55:10.128692-07:00 chenrezi kernel: [ 209.400195] usb 1-3: SerialNumber: Y81V7690CABC66
2021-03-31T16:55:10.156652-07:00 chenrezi kernel: [ 209.429102] usb 1-3: Focusrite Scarlett Gen 2/3 Mixer Driver enabled pid=0x8210
2021-03-31T16:55:10.156695-07:00 chenrezi kernel: [ 209.429759] usb 1-3: Device has no software configuration
2021-03-31T16:55:10.156701-07:00 chenrezi kernel: [ 209.429940] usb 1-3: Scarlett Gen 2 USB response result cmd 800000 was 16 expected 19
2021-03-31T16:55:10.156705-07:00 chenrezi kernel: [ 209.429997] snd-usb-audio: probe of 1-3:1.0 failed with error -22
2021-03-31T16:55:10.166431-07:00 chenrezi mtp-probe: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3"
2021-03-31T16:55:10.167394-07:00 chenrezi mtp-probe: bus: 1, device: 7 was not an MTP device

In kernel 5.11.10-2.gfa5dcf1-default it was:
2021-03-31T16:48:26.892232-07:00 chenrezi kernel: [ 388.071580] usb 1-3: new high-speed USB device number 7 using xhci_hcd
2021-03-31T16:48:27.040176-07:00 chenrezi kernel: [ 388.220024] usb 1-3: New USB device found, idVendor=1235, idProduct=8210, bcdDevice= 5.ff
2021-03-31T16:48:27.040208-07:00 chenrezi kernel: [ 388.220037] usb 1-3: New USB device strings: Mfr=1, Product=3, SerialNumber=2
2021-03-31T16:48:27.040211-07:00 chenrezi kernel: [ 388.220043] usb 1-3: Product: Scarlett 2i2 USB
2021-03-31T16:48:27.040213-07:00 chenrezi kernel: [ 388.220048] usb 1-3: Manufacturer: Focusrite
2021-03-31T16:48:27.040215-07:00 chenrezi kernel: [ 388.220051] usb 1-3: SerialNumber: Y81V7690CABC66
2021-03-31T16:48:27.066796-07:00 chenrezi mtp-probe: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3"
2021-03-31T16:48:27.067211-07:00 chenrezi mtp-probe: bus: 1, device: 7 was not an MTP device
2021-03-31T16:48:27.106776-07:00 chenrezi systemd-udevd[3225]: Process '/usr/sbin/alsactl restore 1' failed with exit code 99.
2021-03-31T16:48:27.110835-07:00 chenrezi systemd[2119]: Reached target Sound Card.

And the Focus Scarlett Gen 3, still works on this kernel, also on the 5.3.18-lp152.66.2.x86_64 kernel.


Please let me know if you need more information.

Kindly,

Peter
Comment 1 Takashi Iwai 2021-04-01 07:57:39 UTC
The error indicated:
  2021-03-31T16:55:10.156705-07:00 chenrezi kernel: [ 209.429997] snd-usb-audio: probe of 1-3:1.0 failed with error -22

This is the code in the mixer quirk specific to Scarlett Gen2, and I don't remember of any major changes.

Could you check the recent upstream kernel (available in OBS Kernel:stable) repo?  Unless you need Nvidia driver or any other KMP and without Secure Boot, the kernel should be usable on top of Leap system.
My guess is that the device won't work with this kernel, too, but this needs verification.
Comment 2 Peter Terpstra 2021-04-01 15:26:07 UTC
Thanks for your answer.

Not sure what you mean with OBS Kernel:stable, my repo was this one:
download.opensuse.org/repositories/home:/in4ops:/internals--c--linux_sys--o--kernel--f--kernel_mainline/openSUSE_Leap_15.2/

This is upstream OBS?
% rpm -qpi kernel-default-5.11.11-lp152.2.1.x86_64.rpm 
Name        : kernel-default
Version     : 5.11.11
Release     : lp152.2.1
Architecture: x86_64
Install Date: (not installed)
Group       : System/Kernel
Size        : 419659137
License     : GPL-2.0
Signature   : RSA/SHA256, Tue 30 Mar 2021 02:26:01 PM PDT, Key ID 8e48d0ac9d74568c
Source RPM  : kernel-default-5.11.11-lp152.2.1.nosrc.rpm
Build Date  : Tue 30 Mar 2021 01:50:26 PM PDT
Build Host  : goat13
Relocations : (not relocatable)
Vendor      : obs://build.opensuse.org/home:in4ops
URL         : http://www.kernel.org/
Summary     : The Standard Kernel
Description :
The standard kernel for both uniprocessor and multiprocessor systems.


Source Timestamp: 2021-03-30 17:57:52 +0000
GIT Revision: dbc4a02972b5d36d666df3c1b25f429cc24db598
GIT Branch: stable
Distribution: home:in4ops:internals--c--linux_sys--o--kernel--f--kernel_mainline / openSUSE_Leap_15.2

Further, note that the Focusrite Scarlett 2i2 used here is the 3rd generation and not the 2nd. In the latest kernel it thinks it is generation 2.

Peter
Comment 3 Takashi Iwai 2021-04-01 15:31:45 UTC
The kernel package of OBS Kernel:stable repo is available at
  http://download.opensuse.org/repositories/Kernel:/stable/standard/

This is the place for the next TW kernel development happens.

And, as you reported as regression: the device worked on which kernel?  We need to narrow down the regression range as small as possible.
Comment 4 Peter Terpstra 2021-04-01 16:06:04 UTC
Thanks that makes it clear.

Happy to say that this kernel works:

/var/log/messages:
2021-04-01T08:35:20.265925-07:00 chenrezi kernel: [ 3255.218351] usb 1-3: new high-speed USB device number 6 using xhci_hcd
2021-04-01T08:35:20.413775-07:00 chenrezi kernel: [ 3255.366983] usb 1-3: New USB device found, idVendor=1235, idProduct=8210, bcdDevice= 5.ff
2021-04-01T08:35:20.413815-07:00 chenrezi kernel: [ 3255.366995] usb 1-3: New USB device strings: Mfr=1, Product=3, SerialNumber=2
2021-04-01T08:35:20.413820-07:00 chenrezi kernel: [ 3255.367001] usb 1-3: Product: Scarlett 2i2 USB
2021-04-01T08:35:20.413824-07:00 chenrezi kernel: [ 3255.367006] usb 1-3: Manufacturer: Focusrite
2021-04-01T08:35:20.414503-07:00 chenrezi kernel: [ 3255.367009] usb 1-3: SerialNumber: Y81V7690CABC66
2021-04-01T08:35:20.423944-07:00 chenrezi mtp-probe: checking bus 1, device 6: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3"
2021-04-01T08:35:20.424954-07:00 chenrezi mtp-probe: bus: 1, device: 6 was not an MTP device
2021-04-01T08:35:20.562669-07:00 chenrezi kernel: [ 3255.515964] usbcore: registered new interface driver snd-usb-audio
2021-04-01T08:35:20.577443-07:00 chenrezi plasmashell[2525]: ERROR from solid predicate parser: syntax error
2021-04-01T08:35:20.628118-07:00 chenrezi systemd-udevd[5024]: Process '/usr/sbin/alsactl restore 1' failed with exit code 99.
2021-04-01T08:35:20.654036-07:00 chenrezi systemd[2216]: Reached target Sound Card.

Which is the 5.11.11-1.gdbc4a02-default
Comment 5 Takashi Iwai 2021-04-02 08:05:03 UTC
Hm, then I don't know what broke in other builds (it looks like some external link with a different setup), but since it works with the official OBS Kernel:stable repo, I close this was WORKSFORME.
Comment 6 Peter Terpstra 2021-04-02 16:34:07 UTC
Actually I did not know that this was not the official kernel.

Got it trough searching here:
https://software.opensuse.org/explore

And already used that repo for some time.

Thanks for your help and have a nice day.

Peter
Comment 7 Peter Terpstra 2021-04-02 18:21:19 UTC
Another problem that is solved now, is the low input volume from the Focusrite scarlett 2i2 3rd gen, now it is way loud as it should be.
This make my day.