Bug 1180402 - Wifi doesn't work in kernel 5.10.1
Wifi doesn't work in kernel 5.10.1
Status: RESOLVED DUPLICATE of bug 1180344
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 openSUSE Tumbleweed
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-28 12:21 UTC by M
Modified: 2020-12-28 12:38 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description M 2020-12-28 12:21:11 UTC
Hi, I've update to kernel 5.10.1 and wifi doesn't work. When the desktop is loaded, automatically go in fly mode and there is no way to turn on wifi. In wicked, I can see the configured device, but it doesn't work, and if I try to scan for networks the popup message "searching for networks" appears just for half a second, then disappear and no networks are found.

My network controller is this (from lshw):

*-network
             description: Network controller
             product: Comet Lake PCH CNVi WiFi
             vendor: Intel Corporation
             physical id: 14.3
             bus info: pci@0000:00:14.3
             version: 00
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi pciexpress msix bus_master cap_list
             configuration: driver=iwlwifi latency=0
             resources: irq:16 memory:c5498000-c549bfff
Comment 1 Takashi Iwai 2020-12-28 12:38:02 UTC
A known iwlwifi problem.  A workaround is found in the duped bug entry.

*** This bug has been marked as a duplicate of bug 1180344 ***