Bug 1180399 - VUL 0: CVE-2020-35730: roundcubemail: cross-site scripting (XSS) vulnerability via HTML or plain text messages with malicious content
VUL 0: CVE-2020-35730: roundcubemail: cross-site scripting (XSS) vulnerabili...
Status: IN_PROGRESS
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Other
Leap 15.2
All openSUSE Leap 15.2
: P5 - None : Major (vote)
: ---
Assigned To: Security Team bot
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-28 10:33 UTC by Lars Vogdt
Modified: 2022-08-03 14:40 UTC (History)
1 user (show)

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Vogdt 2020-12-28 10:33:27 UTC
Roundcube developers released security updates to the stable version 1.4 and the LTS versions 1.3 and 1.2 of Roundcube Webmail. They all contain fixes to a recently reported stored XSS vulnerability.

https://roundcube.net/news/2020/12/27/security-updates-1.4.10-1.3.16-and-1.2.13

openSUSE Leap 15.1 and 15.2 contain the vulnerable 1.3.15 version.


I already updated the package in obs://server:php:applications to 1.4.10, so this should fix Tumbleweed (via SR#858985) in a few hours. 

Maintenance updates for the packages in 15.1 and 15.2 will come in a few minutes.
Comment 1 Lars Vogdt 2020-12-28 10:48:35 UTC
Submitted fixed packages for:
* Backports SLE-15-SP1
* Backports SLE-15-SP2
* Backports SLE-15-SP3
* openSUSE Leap 15.1
* openSUSE Leap 15.2
via openSUSE:Maintenance mr#858988
Comment 2 OBSbugzilla Bot 2020-12-28 11:20:07 UTC
This is an autogenerated message for OBS integration:
This bug (1180399) was mentioned in
https://build.opensuse.org/request/show/858987 Factory / roundcubemail
Comment 3 OBSbugzilla Bot 2021-06-25 17:30:06 UTC
This is an autogenerated message for OBS integration:
This bug (1180399) was mentioned in
https://build.opensuse.org/request/show/902408 Backports:SLE-15-SP1 / roundcubemail
https://build.opensuse.org/request/show/902409 Backports:SLE-15-SP2 / roundcubemail
https://build.opensuse.org/request/show/902411 15.2 / roundcubemail
Comment 4 Swamp Workflow Management 2021-06-27 10:15:34 UTC
openSUSE-SU-2021:0931-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1180399,1187706,1187707
CVE References: CVE-2020-18670,CVE-2020-18671,CVE-2020-35730
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    roundcubemail-1.3.16-lp152.4.6.1
Comment 5 Swamp Workflow Management 2021-06-30 13:44:24 UTC
openSUSE-SU-2021:0942-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1180399,1187706,1187707
CVE References: CVE-2020-18670,CVE-2020-18671,CVE-2020-35730
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP2 (src):    roundcubemail-1.3.16-bp152.4.6.1
Comment 6 Swamp Workflow Management 2021-06-30 14:17:03 UTC
openSUSE-SU-2021:0943-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1180399,1187706,1187707
CVE References: CVE-2020-18670,CVE-2020-18671,CVE-2020-35730
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP1 (src):    roundcubemail-1.3.16-bp151.4.6.1
Comment 7 Swamp Workflow Management 2021-07-06 07:15:42 UTC
openSUSE-SU-2021:0974-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1180399,1187706,1187707
CVE References: CVE-2020-18670,CVE-2020-18671,CVE-2020-35730
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP2 (src):    roundcubemail-1.3.16-bp152.4.14.1
Comment 8 Swamp Workflow Management 2021-07-09 15:48:35 UTC
openSUSE-SU-2021:1014-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1180399,1187706,1187707
CVE References: CVE-2020-18670,CVE-2020-18671,CVE-2020-35730
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP2 (src):    roundcubemail-1.3.16-bp152.4.18.1
Comment 9 OBSbugzilla Bot 2022-08-03 14:40:05 UTC
This is an autogenerated message for OBS integration:
This bug (1180399) was mentioned in
https://build.opensuse.org/request/show/992584 Backports:SLE-15-SP3+Backports:SLE-15-SP4 / roundcubemail