Bug 1180381 - [Build 20201225] [s390x] Kernel Panic - No TPM chip found, activating TPM-bypass
[Build 20201225] [s390x] Kernel Panic - No TPM chip found, activating TPM-bypass
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P2 - High : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
https://openqa.opensuse.org/tests/152...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-27 11:28 UTC by Sarah Julia Kriesch
Modified: 2021-01-11 17:03 UTC (History)
5 users (show)

See Also:
Found By: openQA
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---
slindomansilla: needinfo? (ihno)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sarah Julia Kriesch 2020-12-27 11:28:52 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-s390x-textmode-server@s390x-zVM-vswitch-l2 fails in
[bootloader_s390](https://openqa.opensuse.org/tests/1529101/modules/bootloader_s390/steps/30)

We have received a Kernel Panic only for s390x. Therefore, it seems to be s390x specific. All s390x test suites are failing in openQA.

Most important messages are following:
- ap: The hardware system does not support AP instructions
- page_owner is disabled
-  ima: No TPM chip found, activating TPM-bypass!
- ima: No architecture policies found  
-  VFS: Cannot open root device "(null)" or unknown-block(1,0): error -6 
- Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)  

Test suite bsc1178790 has got routing problems as a result. Test suites textmode and textmode-server have got login problems with the x3270 console.           

## Test suite description
bootloader_start and bootloader_s390 are using both the test bootloader_s390 to start the system.


## Reproducible

Fails since (at least) Build [20201110](https://openqa.opensuse.org/tests/1466939)


## Expected result
A working system start without any kernel panic


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=s390x&distri=opensuse&flavor=DVD&machine=s390x-zVM-vswitch-l2&test=textmode-server&version=Tumbleweed)
Comment 1 Sarah Kriesch 2020-12-27 12:00:49 UTC
The output of the Kernel Panic:

'    84 *-* /* punchfiles: */                                                    ',
          '    86 *-* \'spool punch *\'                                                      ',
          '       >>>   "spool punch *"                                                    ',
          '    87 *-* \'close reader\'                                                       ',
          '       >>>   "close reader"                                                     ',
          '    88 *-* \'purge reader all\'                                                   ',
          '       >>>   "purge reader all"                                                 ',
          '00:      NO FILES PURGED                                                        ',
          '    89 *-* \'punch ftpboot kern t (noh\'                                          ',
          '       >>>   "punch ftpboot kern t (noh"                                        ',
          '00: RDR FILE 0150 SENT FROM LINUX146 PUN WAS 0150 RECS 104K CPY  001 A NOHOLD NO',
          'KEEP                                                                            ',
          '    90 *-* \'punch ftpboot parm t (noh\'                                          ',
          '       >>>   "punch ftpboot parm t (noh"                                        ',
          '00: RDR FILE 0151 SENT FROM LINUX146 PUN WAS 0151 RECS 0007 CPY  001 A NOHOLD NO',
          'KEEP                                                                            ',
          '    91 *-* \'punch ftpboot initrd t (noh\'                                        ',
          '       >>>   "punch ftpboot initrd t (noh"                                      ',
          'DMSPUN044E Record exceeds allowable maximum                                     ',
          '       +++ RC(32) +++                                                           ',
          '    93 *-* ipl 00c clear                                                        ',
          '       >>>   "IPL 00C CLEAR"                                                    ',
          '00:      NO FILES CHANGED                                                       ',
          '[    0.108008] Linux version 5.10.1-1-default (geeko@buildhost) (gcc (SUSE Linux',
          ') 10.2.1 20201202 [revision e563687cf9d3d1278f45aaebd03e0f66531076c9], GNU ld (G',
          'NU Binutils; openSUSE:Factory:zSystems) 2.35.1.20201112-1) #1 SMP Sun Dec 20 07:',
          '24:34 UTC 2020 (d14c73f)                                                        ',
          '[    0.108011] setup: Linux is running as a z/VM guest operating system in 64-bi',
          't mode                                                                          ',
          '[    0.109948] setup: The maximum memory size is 1024MB                         ',
          '[    0.109950] cma: Reserved 4 MiB at 0x000000003fc00000                        ',
          '[    0.110122] cpu: 2 configured CPUs, 0 standby CPUs                           ',
          '[    0.110277] Write protected kernel read-only data: 14900k                    ',
          '[    0.110304] Zone ranges:                                                     ',
          '[    0.110305]   DMA      [mem 0x0000000000000000-0x000000007fffffff]           ',
          '[    0.110307]   Normal   empty                                                 ',
          '[    0.110308] Movable zone start for each node                                 ',
          '[    0.110309] Early memory node ranges                                         ',
          '[    0.110310]   node   0: [mem 0x0000000000000000-0x000000003fffffff]          ',
          '[    0.110312] Initmem setup node 0 [mem 0x0000000000000000-0x000000003fffffff] ',
          '[    0.123953] percpu: Embedded 33 pages/cpu s98048 r8192 d28928 u135168        ',
          '[    0.124038] Built 1 zonelists, mobility grouping on.  Total pages: 258048    ',
          '[    0.124039] Policy zone: DMA                                                 ',
          '[    0.124040] Kernel command line: hardened_usercopy=off VNCPassword=nots3cr3t ',
          'sshpassword=nots3cr3t VNC=1         Nameserver=192.168.112.100 HostIP=192.168.11',
          '2.146/24 OSAInterface=qdio          ReadChannel=0.0.0800 DataChannel=0.0.0802 Do',
          'main=opensuse.org PortNo=0          install=ftp://192.168.112.100/Tumbleweed-oss',
          '-s390x-Snapshot20201225             Gateway=192.168.112.254 Hostname=s390linux14',
          '6 WriteChannel=0.0.0801             VNCSize=1024x768 InstNetDev=osa OSAMedium=et',
          'h OSAHWAddr= hvc_iucv=8             hvc_iucv=8 Layer2=1 sshd=1                  ',
          '[    0.124148] printk: log_buf_len individual max cpu contribution: 32768 bytes ',
          '[    0.124149] printk: log_buf_len total cpu_extra contributions: 2064384 bytes ',
          '[    0.124150] printk: log_buf_len min size: 131072 bytes                       ',
          '[    0.131584] printk: log_buf_len: 4194304 bytes                               ',
          '[    0.131586] printk: early log buf free: 128416(97%)                          ',
          '[    0.131975] Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes,',
          ' linear)                                                                        ',
          '[    0.132161] Inode-cache hash table entries: 65536 (order: 7, 524288 bytes, li',
          'near)                                                                           ',
          '[    0.132179] mem auto-init: stack:off, heap alloc:off, heap free:off          ',
          '[    0.151486] Memory: 968952K/1048576K available (12192K kernel code, 2328K rwd',
          'ata, 2708K rodata, 3708K init, 9084K bss, 75528K reserved, 4096K cma-reserved)  ',
          '[    0.151490] random: get_random_u64 called from __kmem_cache_create+0x42/0x176',
          '0 with crng_init=0                                                              ',
          '[    0.151732] SLUB: HWalign=256, Order=0-3, MinObjects=0, CPUs=64, Nodes=1     ',
          '[    0.151744] ftrace: allocating 26724 entries in 105 pages                    ',
          '[    0.160132] ftrace: allocated 105 pages with 4 groups                        ',
          '[    0.160358] rcu: Hierarchical RCU implementation.                            ',
          '[    0.160358] rcu:     RCU event tracing is enabled.                           ',
          '[    0.160360] rcu:     RCU restricting CPUs from NR_CPUS=512 to nr_cpu_ids=64. ',
          '[    0.160361]  Trampoline variant of Tasks RCU enabled.                        ',
          '[    0.160361]  Rude variant of Tasks RCU enabled.                              ',
          '[    0.160362]  Tracing variant of Tasks RCU enabled.                           ',
          '[    0.160363] rcu: RCU calculated value of scheduler-enlistment delay is 10 jif',
          'fies.                                                                           ',
          '[    0.160364] rcu: Adjusting geometry for rcu_fanout_leaf=16, nr_cpu_ids=64    ',
          '[    0.164304] NR_IRQS: 3, nr_irqs: 3, preallocated irqs: 3                     ',
          '[    0.164358] clocksource: tod: mask: 0xffffffffffffffff max_cycles: 0x3b0a9be8',
          '03b0a9, max_idle_ns: 1805497147909793 ns                                        ',
          '[    0.164404] Console: colour dummy device 80x25                               ',
          '[    0.166647] random: fast init done                                           ',
          '[    0.168996] printk: console [ttyS0] enabled                                  ',
          '[    0.169090] pid_max: default: 65536 minimum: 512                             ',
          '[    0.169162] LSM: Security Framework initializing                             ',
          '[    0.169181] AppArmor: AppArmor initialized                                   ',
          '[    0.169218] Mount-cache hash table entries: 2048 (order: 2, 16384 bytes, line',
          'ar)                                                                             ',
          '[    0.169222] Mountpoint-cache hash table entries: 2048 (order: 2, 16384 bytes,',
          ' linear)                                                                        ',
          '[    0.169707] rcu: Hierarchical SRCU implementation.                           ',
          '01: HCPGSP2627I The virtual machine is placed in CP mode due to a SIGP initial C',
          'PU reset from CPU 00.                                                           ',
          '01: HCPGSP2629I The virtual machine is placed in CP mode due to a SIGP stop from',
          ' CPU 01.                                                                        ',
          '01: HCPGSP2629I The virtual machine is placed in CP mode due to a SIGP stop from',
          ' CPU 00.                                                                        ',
          '[    0.170342] smp: Bringing up secondary CPUs ...                              ',
          '[    0.170525] smp: Brought up 1 node, 2 CPUs                                   ',
          '[    0.170915] devtmpfs: initialized                                            ',
          '[    0.171113] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, ma',
          'x_idle_ns: 19112604462750000 ns                                                 ',
          '[    0.171175] futex hash table entries: 16384 (order: 10, 4194304 bytes, linear',
          ')                                                                               ',
          '[    0.171787] NET: Registered protocol family 16                               ',
          '[    0.171823] audit: initializing netlink subsys (disabled)                    ',
          '[    0.171859] audit: type=2000 audit(1608991660.791:1): state=initialized audit',
          '_enabled=0 res=1                                                                ',
          '[    0.171897] Spectre V2 mitigation: execute trampolines                       ',
          '[    0.172923] HugeTLB registered 1.00 MiB page size, pre-allocated 0 pages     ',
          '[    0.174520] iommu: Default domain type: Translated                           ',
          '[    0.174734] NetLabel: Initializing                                           ',
          '[    0.174735] NetLabel:  domain hash size = 128                                ',
          '[    0.174736] NetLabel:  protocols = UNLABELED CIPSOv4 CALIPSO                 ',
          '[    0.174747] NetLabel:  unlabeled traffic allowed by default                  ',
          '[    0.174803] cio: Partition identifier 0.1                                    ',
          '[    0.193478] VFS: Disk quotas dquot_6.6.0                                     ',
          '[    0.193507] VFS: Dquot-cache hash table entries: 512 (order 0, 4096 bytes)   ',
          '[    0.193607] AppArmor: AppArmor Filesystem Enabled                            ',
          '[    0.194855] NET: Registered protocol family 2                                ',
          '[    0.194989] tcp_listen_portaddr_hash hash table entries: 512 (order: 1, 8192 ',
          'bytes, linear)                                                                  ',
          '[    0.194994] TCP established hash table entries: 8192 (order: 4, 65536 bytes, ',
          'linear)                                                                         ',
          '[    0.195016] TCP bind hash table entries: 8192 (order: 5, 131072 bytes, linear',
          ')                                                                               ',
          '[    0.195043] TCP: Hash tables configured (established 8192 bind 8192)         ',
          '[    0.195137] MPTCP token hash table entries: 1024 (order: 2, 24576 bytes, line',
          'ar)                                                                             ',
          '[    0.195148] UDP hash table entries: 512 (order: 2, 16384 bytes, linear)      ',
          '[    0.195153] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes, linear) ',
          '[    0.195260] NET: Registered protocol family 1                                ',
          '[    0.195264] NET: Registered protocol family 44                               ',
          '[    0.195270] PCI: CLS 0 bytes, default 256                                    ',
          '[    0.195854] Initialise system trusted keyrings                               ',
          '[    0.195860] Key type blacklist registered                                    ',
          '[    0.195889] workingset: timestamp_bits=45 max_order=18 bucket_order=0        ',
          '[    0.197068] zbud: loaded                                                     ',
          '[    0.197441] integrity: Platform Keyring initialized                          ',
          '[    0.208105] Key type asymmetric registered                                   ',
          '[    0.208107] Asymmetric key parser \'x509\' registered                          ',
          '[    0.208112] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 2',
          '49)                                                                             ',
          '[    0.208209] io scheduler mq-deadline registered                              ',
          '[    0.208210] io scheduler kyber registered                                    ',
          '[    0.208233] io scheduler bfq registered                                      ',
          '[    0.208274] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4     ',
          '[    0.208696] mousedev: PS/2 mouse device common for all mice                  ',
          '[    0.208724] drop_monitor: Initializing network drop monitor service          ',
          '[    0.208871] NET: Registered protocol family 10                               ',
          '[    0.209762] Segment Routing with IPv6                                        ',
          '[    0.209764] RPL Segment Routing with IPv6                                    ',
          '[    0.209828] cio: Channel measurement facility initialized using format extend',
          'ed (mode autodetected)                                                          ',
          '[    0.210048] ap: The hardware system does not support AP instructions         ',
          '[    0.210073] registered taskstats version 1                                   ',
          '[    0.210075] Loading compiled-in X.509 certificates                           ',
          '[    0.210439] Loaded X.509 cert \'openSUSE:Factory:zSystems OBS Project: efd2a4b',
          '06f15dcfbfe37d3696baaa0a986731049\'                                              ',
          '[    0.210453] zswap: loaded using pool lzo/zbud                                ',
          '[    0.210729] page_owner is disabled                                           ',
          '[    0.210791] Key type ._fscrypt registered                                    ',
          '[    0.210792] Key type .fscrypt registered                                     ',
          '[    0.210793] Key type fscrypt-provisioning registered                         ',
          '[    0.210951] Key type encrypted registered                                    ',
          '[    0.210954] AppArmor: AppArmor sha1 policy hashing enabled                   ',
          '[    0.210957] ima: No TPM chip found, activating TPM-bypass!                   ',
          '[    0.210960] ima: Allocated hash algorithm: sha256                            ',
          '[    0.210966] ima: No architecture policies found                              ',
          '[    0.210972] evm: Initialising EVM extended attributes:                       ',
          '[    0.210973] evm: security.selinux                                            ',
          '[    0.210974] evm: security.apparmor                                           ',
          '[    0.210975] evm: security.ima                                                ',
          '[    0.210976] evm: security.capability                                         ',
          '[    0.210977] evm: HMAC attrs: 0x1                                             ',
          '[    0.211243] VFS: Cannot open root device "(null)" or unknown-block(1,0): erro',
          'r -6                                                                            ',
          '[    0.211245] Please append a correct "root=" boot option; here are the availab',
          'le partitions:                                                                  ',
          '[    0.211246] Kernel panic - not syncing: VFS: Unable to mount root fs on unkno',
          'wn-block(1,0)                                                                   ',
          '[    0.211249] CPU: 0 PID: 1 Comm: swapper/0 Not tainted 5.10.1-1-default #1 ope',
          'nSUSE Tumbleweed                                                                ',
          '[    0.211250] Hardware name: IBM 2964 N63 400 (z/VM 6.4.0)                     ',
          '[    0.211251] Call Trace:                                                      ',
          '[    0.211254]  [<000000003252e15c>] show_stack+0x8c/0xd8                       ',
          '[    0.211256]  [<0000000032533550>] dump_stack+0x90/0xc0                       ',
          '[    0.211258]  [<000000003252eae2>] panic+0x112/0x308                          ',
          '[    0.211261]  [<0000000032a39b98>] mount_block_root+0x2e0/0x368               ',
          '[    0.211263]  [<0000000032a39e0a>] prepare_namespace+0x162/0x198              ',
          '[    0.211265]  [<0000000032a3965a>] kernel_init_freeable+0x2c2/0x2d0           ',
          '[    0.211267]  [<0000000032536692>] kernel_init+0x22/0x150                     ',
          '[    0.211269]  [<0000000032546b20>] ret_from_fork+0x28/0x2c                    ',
          '00: HCPGIR450W CP entered; disabled wait PSW 00020001 80000000 00000000 31977BCE'
Comment 2 Petr Tesařík 2020-12-27 17:00:17 UTC
(In reply to Sarah Kriesch from comment #1)
>           '    91 *-* \'punch ftpboot initrd t (noh\'                       
> ',
>           '       >>>   "punch ftpboot initrd t (noh"                       
> ',
>           'DMSPUN044E Record exceeds allowable maximum                      
> ',
>           '       +++ RC(32) +++                                            
> ',

AFAICS this is the root cause. The initrd could not be added to the virtual punch. Since no block device driver is built in, and the dasd kernel module was in the initrd (which is missing), the kernel cannot mount any root device and panics.

I'd like to understand why we're getting the DMS044E error message from CMS.
Comment 3 Berthold Gunreben 2020-12-27 22:46:35 UTC
(In reply to Petr Tesařík from comment #2)
> (In reply to Sarah Kriesch from comment #1)
> >           '    91 *-* \'punch ftpboot initrd t (noh\'                       
> > ',
> >           '       >>>   "punch ftpboot initrd t (noh"                       
> > ',
> >           'DMSPUN044E Record exceeds allowable maximum                      
> > ',
> >           '       +++ RC(32) +++                                            
> > ',
> 
> AFAICS this is the root cause. The initrd could not be added to the virtual
> punch. Since no block device driver is built in, and the dasd kernel module
> was in the initrd (which is missing), the kernel cannot mount any root
> device and panics.
> 
> I'd like to understand why we're getting the DMS044E error message from CMS.

Good catch. And it I also don't understand it so far. So, what qaboot does is retrieve the file (ftpboot.initrd.t) from the ftpserver, and then uses pipe with fblock to created fixed length records.

'pipe < ftpboot initrd t | fblock 80 00 | > ftpboot initrd t'

For some reason, that does not seem to work as desired. For a slightly more verbose version of the error, see

https://www.vm.ibm.com/library/640pdfs/64616105.pdf

Page 43 (PDF Page 57):
Explanation: The record length given exceeds the maximum record length allowed. For more information on the maximum record lengths allowed by the EDIT,PRINT and PUNCH commands, refer to z/VM: CMS Commands and Utilities Reference. 

System action:RC=32. Execution of the command is terminated. The system status remains the same.
User response:
...
For DMSPUN, you can change the record length with the COPYFILE command, and then reissue thecommand.

Maybe we could have a LISTFILE on the contents of the T mode before the files get punched (would have to be added to qaboot rexx).
Comment 4 Berthold Gunreben 2020-12-28 08:46:06 UTC
(In reply to Berthold Gunreben from comment #3)
> (In reply to Petr Tesařík from comment #2)
> > I'd like to understand why we're getting the DMS044E error message from CMS.
> 
> Good catch. And it I also don't understand it so far. So, what qaboot does
> is retrieve the file (ftpboot.initrd.t) from the ftpserver, and then uses
> pipe with fblock to created fixed length records.
> 
> 'pipe < ftpboot initrd t | fblock 80 00 | > ftpboot initrd t'
> 
> For some reason, that does not seem to work as desired. 

I should have read the next line:

'DMSERD107S Disk T(FFFF) is full    

This is a disk in memory, and as you can see from the log, it has 20000 Blocks (with 512 Bytes each)

10MB is definitly not enough for kernel and initrd, this looks like a setup issue in z/VM.

Ihno, could you please have a look?
Comment 5 Sarah Julia Kriesch 2020-12-28 10:00:04 UTC
One additional hint: We did not receive any iso image into openQA about 7 days before this Kernel Panic.
Comment 6 Berthold Gunreben 2020-12-28 10:27:33 UTC
(In reply to Berthold Gunreben from comment #4)
> (In reply to Berthold Gunreben from comment #3)
> > (In reply to Petr Tesařík from comment #2)
> > > I'd like to understand why we're getting the DMS044E error message from CMS.
> > 
> > Good catch. And it I also don't understand it so far. So, what qaboot does
> > is retrieve the file (ftpboot.initrd.t) from the ftpserver, and then uses
> > pipe with fblock to created fixed length records.
> > 
> > 'pipe < ftpboot initrd t | fblock 80 00 | > ftpboot initrd t'
> > 
> > For some reason, that does not seem to work as desired. 
> 
> I should have read the next line:
> 
> 'DMSERD107S Disk T(FFFF) is full    
> 
> This is a disk in memory, and as you can see from the log, it has 20000
> Blocks (with 512 Bytes each)
> 
> 10MB is definitly not enough for kernel and initrd, this looks like a setup
> issue in z/VM.
> 
> Ihno, could you please have a look?

sorry, it is not 20000, but 200000 blocks. However, it looks like this is not enough. This should be increased in qaboot exec, please search for the line

'define vfb-512 as ffff blk 200000'

and update accordingly.
Comment 7 Sarah Julia Kriesch 2020-12-29 12:31:13 UTC
Today we have got a full disk instead of a Kernel Panic:

DMSERD107S Disk T(FFFF) is full                                                 ',
          ' FTPBOOT  PARM     T1  V 80  Trunc=80 Size=6 Line=7 Col=1 Alt=8                 ',
          'DMSXFW531E Disk or file space is full; set new filemode or clear some space     ',
          '00000 * * * Top of File * * *
Comment 8 Ihno Krumreich 2020-12-30 14:19:06 UTC
(In reply to Berthold Gunreben from comment #4)
> (In reply to Berthold Gunreben from comment #3)
> > (In reply to Petr Tesařík from comment #2)
> > > I'd like to understand why we're getting the DMS044E error message from CMS.
> > 
> > Good catch. And it I also don't understand it so far. So, what qaboot does
> > is retrieve the file (ftpboot.initrd.t) from the ftpserver, and then uses
> > pipe with fblock to created fixed length records.
> > 
> > 'pipe < ftpboot initrd t | fblock 80 00 | > ftpboot initrd t'
> > 
> > For some reason, that does not seem to work as desired. 
> 
> I should have read the next line:
> 
> 'DMSERD107S Disk T(FFFF) is full    
> 
> This is a disk in memory, and as you can see from the log, it has 20000
> Blocks (with 512 Bytes each)
> 
> 10MB is definitly not enough for kernel and initrd, this looks like a setup
> issue in z/VM.
> 
> Ihno, could you please have a look?


I checked the guest and there is no limit in the size the guest can allocate.
Also the size currently allocated in the system is far away from being a limit.
We use the value 200000 also in ftpboot and up to now we had no problem.

Of course you are free to increase the value, but I think we should have a look at the disk of a crashed system.
Comment 9 Ihno Krumreich 2020-12-30 15:11:22 UTC
The content of the disk is the following:

 LINUX146 FILELIST A0  V 169  Trunc=169 Size=5 Line=1 Col=1 Alt=18
Cmd Filename Filetype Fm Format Lrecl    Records     Blocks   Date       Time
*   FTPBOOT  PARM     K1 V         70          6          1 2020-12-30 06:48:39
    FTPBOOT  INITRD   K1 V       8192       5673      11348 2020-12-30 06:48:34
    FTPBOOT  KERN     K1 V         80     104353       2090 2020-12-30 06:48:34
*   00EB5CA8 CMSUT1   K1 V         80     573040      11472 2020-12-30 06:48:34
    SUSE     INS      K1 V         57          6          1 2020-12-30 06:48:29


Doing the math shows that the disk is full. The unusual file is 00EB5CA8 CMSUT1.
According to Google this is a temporary file created by CMS commands.

In qaboot he suspect is 
"pipe < ftpboot initrd t | fblock 80 00 | > ftpboot initrd t"
This converts the fresh downloaded file into a 80-Byte fixed block file.

I did the following change to qaboot:

- Increased the size of the VDSK disk from 200000 to 300000 Blocks
- exchanged the sequence of the download of initrd and kernel
  (not shure whether this has a real effect)

can someone please restart the test?
Comment 10 Ihno Krumreich 2020-12-30 16:06:28 UTC
I did a manual test with
qaboot 192.168.112.100 Tumbleweed-oss-s390x-Snapshot20201229
The system booted and then stopped in the linuxrc for futher action.

Doing the math for the temp disk showed that (include a temp file of the initrd size) the disk needs to have a size of 202784 blocks.
Comment 11 Ihno Krumreich 2020-12-30 16:31:50 UTC
Additional change in qaboot:

The FTP-client can store downloaded file in the fixed record format {"locsite fix 80" command).
I added that command to the download sequence and commented out the two command for doing this after the download.
Comment 12 Sarah Julia Kriesch 2020-12-31 07:21:49 UTC
I have restarted the tests and it seems there are no problems in the bootloader section any more:
https://openqa.opensuse.org/tests/1536533#details

Thank you, Ihno!
Comment 13 Sarah Julia Kriesch 2020-12-31 10:53:19 UTC
The system configuration has fixed the Kernel Panic.
Comment 14 Sergio Lindo Mansilla 2021-01-11 17:03:30 UTC
Ihno, I suppose that you only changed qaboot on the z/VM guests for openqa.opensuse.org.

I can still find 200000 in `qaboot exec a` on auto-mounted disk A -> MNT191 on z/VM guests for openqa.suse.de.

Could you update it too?