Bug 1180376 - Frequent panics and degraded performance in Kernel 5.10.1-default
Frequent panics and degraded performance in Kernel 5.10.1-default
Status: RESOLVED DUPLICATE of bug 1180344
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 openSUSE Tumbleweed
: P5 - None : Major (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-26 21:23 UTC by Klein Kravis
Modified: 2020-12-28 22:25 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Klein Kravis 2020-12-26 21:23:44 UTC
I updated to Kernel 5.10 and have had some issues. Most of the time it doesn't even boot due to workqueue lockup, but when it does the performance is severely degraded. I have decided to stay on Kernel 5.9 for the time being but would like to be able to update.

/etc/os-release:
NAME="openSUSE Tumbleweed"
# VERSION="20201224"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20201224"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20201224"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
DOCUMENTATION_URL="https://en.opensuse.org/Portal:Tumbleweed"
LOGO="distributor-logo"

Hardware:
    Manufacturer:  Lenovo
    Model:  ThinkBook 13s IWL (First Generation)
    Form Factor: Laptop

    CPU Vendor:  GenuineIntel
    CPU Brand:  Intel(R) Core(TM) i5-8265U CPU @ 1.60GHz
    CPU Family:  0x6
    CPU Model:  0x8e
    CPU Stepping:  0xc
    CPU Type:  0x0
    Speed:  3900 Mhz
    8 logical processors
    4 physical processors
    HyperThreading:  Supported

    Video Card: Intel UHD Graphics 620
    Driver:  Intel Open Source Technology Center Mesa DRI Intel(R)
    Driver Version:  3.0 Mesa 20.2.4
    
    Audio device: Realtek ALC257

    RAM:  7637 Mb

    Total Hard Disk Space Available:  196593 Mb
    Largest Free Hard Disk Block:  176467 Mb
Comment 1 Frank Krüger 2020-12-26 21:38:17 UTC
See bug 1180344.
Comment 2 Takashi Iwai 2020-12-27 08:01:48 UTC
Could you check the workaround suggested in
  https://apibugzilla.suse.com/show_bug.cgi?id=1180344#c16
?

In anyway, please give dmesg output with the workqueue lock up.
Comment 3 Klein Kravis 2020-12-28 22:22:24 UTC
(In reply to Takashi Iwai from comment #2)
> Could you check the workaround suggested in
>   https://apibugzilla.suse.com/show_bug.cgi?id=1180344#c16
> ?
> 
> In anyway, please give dmesg output with the workqueue lock up.

This workaround fixed the issues
Comment 4 Klein Kravis 2020-12-28 22:24:51 UTC
Disabling logging fixes this bug. This is a rather severe bug and I will be proposing it as a Final Blocker for Fedora 34

*** This bug has been marked as a duplicate of bug 1180344 ***