Bug 1180360 - System hangs on kernel 5.10
System hangs on kernel 5.10
Status: RESOLVED DUPLICATE of bug 1180344
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 openSUSE Tumbleweed
: P1 - Urgent : Critical (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-25 17:21 UTC by Gertjan Lettink
Modified: 2020-12-25 23:54 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gertjan Lettink 2020-12-25 17:21:23 UTC
System hangs with following message:

BUG: unable to handle page fault for address: ffffb6740145f39f

This on a Tuxedo Infinity laptop, kernel 5.9.x are all OK.
Comment 1 Eric Renfro 2020-12-25 19:13:19 UTC
I'm experiencing the same issue, as shown on this camera shot of the issue:
https://i.imgur.com/ZDOkido.jpg

Not sure if it's exactly the same, but similar on boot full stop workqueue lockup of the CPU.

Lenovo Yoga C740-14IML

Booting with Kernel 5.9.14 remains fully functional.
Comment 2 Eric Renfro 2020-12-25 19:44:59 UTC
I have a strong suspicion that this is related to bluetooth. Once the bluetooth service starts, or btintel modules are loaded, that's when the boot process fails and starts throwing fits.

And I noticed in this posting https://lwn.net/Articles/835774/ there was some significant changes in 5.10 regarding ABI and bluetooth.
Comment 3 Adam Stephens 2020-12-25 22:41:28 UTC
Is this a duplicate of http://bugzilla.opensuse.org/show_bug.cgi?id=1180344 ?
Comment 4 Frank Krüger 2020-12-25 23:39:01 UTC
(In reply to Adam Stephens from comment #3)
> Is this a duplicate of http://bugzilla.opensuse.org/show_bug.cgi?id=1180344 ?

Does the workaround mentioned in https://bugzilla.opensuse.org/show_bug.cgi?id=1180344#c16 work for you?
Comment 5 Gertjan Lettink 2020-12-25 23:51:32 UTC
(In reply to Frank Krüger from comment #4)
> (In reply to Adam Stephens from comment #3)
> > Is this a duplicate of http://bugzilla.opensuse.org/show_bug.cgi?id=1180344 ?
> 
> Does the workaround mentioned in
> https://bugzilla.opensuse.org/show_bug.cgi?id=1180344#c16 work for you?

Yep, that works for me.
Comment 6 Frank Krüger 2020-12-25 23:54:14 UTC
Dup of bug 1180344.

*** This bug has been marked as a duplicate of bug 1180344 ***