Bug 1180352 - Download manager KGet does not start
Download manager KGet does not start
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: KDE Applications
Jump 15.2.1
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-25 09:29 UTC by Igor Arbichev
Modified: 2021-01-09 05:16 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Screenshot. (202.98 KB, image/png)
2020-12-25 09:29 UTC, Igor Arbichev
Details
Screenshot from Laptop. (120.31 KB, image/png)
2020-12-27 15:30 UTC, Igor Arbichev
Details
Screenshot from Laptop. (256.14 KB, image/png)
2020-12-29 09:23 UTC, Igor Arbichev
Details
Screenshot from Laptop. (341.86 KB, image/png)
2020-12-29 09:38 UTC, Igor Arbichev
Details
Screenshot from Laptop. (343.00 KB, image/png)
2020-12-29 10:52 UTC, Igor Arbichev
Details
Screenshot from Laptop. (635.17 KB, image/png)
2020-12-30 15:03 UTC, Igor Arbichev
Details
Error file (7.47 KB, text/plain)
2020-12-30 15:16 UTC, Igor Arbichev
Details
Screenshot from Laptop. (731.39 KB, image/png)
2021-01-02 14:31 UTC, Igor Arbichev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Arbichev 2020-12-25 09:29:24 UTC
Created attachment 844704 [details]
Screenshot.

The download manager KGet does not start. When trying to start from the terminal, the following message is displayed (see screenshot).
Comment 1 Fabian Vogt 2020-12-25 10:22:26 UTC
The issue is that you're trying to run it inside su, that will not work. You have to start it normally.
Comment 2 Igor Arbichev 2020-12-25 10:46:21 UTC
I've tried running from both a regular user and from a root. In both cases, it does not start.
Comment 3 Fabian Vogt 2020-12-25 10:48:06 UTC
What's the terminal output when you run it normally?
Comment 4 Igor Arbichev 2020-12-27 15:30:46 UTC
Created attachment 844715 [details]
Screenshot from Laptop.

Start from normal user.
Comment 5 Igor Arbichev 2020-12-27 15:31:41 UTC
Start from normal user.
Comment 6 Fabian Vogt 2020-12-27 15:38:21 UTC
That's normal - kget starts in the background. Do you see the symbol in the system tray? (Click on the black triangle)
Comment 7 Igor Arbichev 2020-12-29 09:23:29 UTC
Created attachment 844738 [details]
Screenshot from Laptop.

When trying to download a specific file, KGet breaks. Explain, what am I doing wrong?
Comment 8 Igor Arbichev 2020-12-29 09:38:54 UTC
Created attachment 844740 [details]
Screenshot from Laptop.

Send additional Information.
Comment 9 Christophe Giboudeaux 2020-12-29 10:24:06 UTC
Is "admin" the user that opened the session or is it only running kget in another user's session?
Comment 10 Christophe Giboudeaux 2020-12-29 10:25:21 UTC
What does 'xauth list' return?
Comment 11 Igor Arbichev 2020-12-29 10:48:43 UTC
(In reply to Christophe Giboudeaux from comment #9)
> Is "admin" the user that opened the session or is it only running kget in
> another user's session?

Yes, ¨admin¨ is the user, that opened the session.
Comment 12 Igor Arbichev 2020-12-29 10:52:21 UTC
Created attachment 844741 [details]
Screenshot from Laptop.

Please, send Screenshot.
Comment 13 Fabian Vogt 2020-12-30 13:52:09 UTC
What does drkonqi say on the second tab?
Comment 14 Igor Arbichev 2020-12-30 15:03:31 UTC
Created attachment 844755 [details]
Screenshot from Laptop.

I send second Tab from DrKonqi.
Comment 15 Fabian Vogt 2020-12-30 15:05:56 UTC
Comment on attachment 844755 [details]
Screenshot from Laptop.

Please save the whole backtrace output as file (there's a button) and attach it to this bug report.
Comment 16 Igor Arbichev 2020-12-30 15:16:55 UTC
Created attachment 844756 [details]
Error file

File from DrKonqi.
Comment 17 Fabian Vogt 2020-12-30 16:27:03 UTC
I couldn't reproduce the crash, but Valgrind complained about some issues there which I fixed: https://invent.kde.org/network/kget/-/merge_requests/10

Please try kget from here, once built: https://build.opensuse.org/package/show/home:Vogtinator:boo1180352/kget.openSUSE_Leap_15.2_Update
Comment 18 Igor Arbichev 2021-01-02 14:31:26 UTC
Created attachment 844780 [details]
Screenshot from Laptop.

I followed your instructions - I replaced the KGet package from the Jump repository with a package from the Leap repository. Everything is working. But I understand that this is a forced decision. It is desirable that the package KGet work from the Jump repository.
Happy New Year!
Comment 19 OBSbugzilla Bot 2021-01-02 15:30:05 UTC
This is an autogenerated message for OBS integration:
This bug (1180352) was mentioned in
https://build.opensuse.org/request/show/859843 15.2 / kget
Comment 20 Swamp Workflow Management 2021-01-05 23:15:37 UTC
openSUSE-RU-2021:0019-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1180352
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    kget-20.04.2-lp152.2.3.1
Comment 21 Fabian Vogt 2021-01-05 23:22:10 UTC
Fix landed in 15.2 and TW.

(In reply to Igor Arbichev from comment #18)
> Created attachment 844780 [details]
> Screenshot from Laptop.
> 
> I followed your instructions - I replaced the KGet package from the Jump
> repository with a package from the Leap repository. Everything is working.
> But I understand that this is a forced decision. It is desirable that the
> package KGet work from the Jump repository.

Note that Jump 15.2.1 is dead - it won't get any updates. So I recommend switching back to 15.2 or trying out 15.3 (but might be too early for that).

> Happy New Year!

You too!
Comment 22 Swamp Workflow Management 2021-01-09 05:16:14 UTC
openSUSE-RU-2021:0036-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1180352
CVE References: 
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP2 (src):    kget-20.04.2-bp152.2.3.1