Bug 1179951 - my laptop wakes up from sleep to booting
my laptop wakes up from sleep to booting
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 15.2
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-11 13:28 UTC by A.Rahman Mahmoud
Modified: 2020-12-18 09:20 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
sudo journalctl -b -1 (217.76 KB, text/x-vhdl)
2020-12-11 13:28 UTC, A.Rahman Mahmoud
Details

Note You need to log in before you can comment on or make changes to this bug.
Description A.Rahman Mahmoud 2020-12-11 13:28:06 UTC
Created attachment 844399 [details]
sudo journalctl -b -1

I have reinstalled leap 15.2, that's it I just reinstalled it and now when my laptop sleeps it appears from the laptop's LEDs that it's in sleep mode, but when I press the power button it boots as if it wasn't on.
I'm not sure what logs you would need, this is my journalctl.
Comment 1 Takashi Iwai 2020-12-11 13:33:38 UTC
Could you try the older Leap 15.2 kernel and see whether the same problem happens?  With "zypper se -s kernel-default", you'll see various kernel versions, and you can install the old version explicitly by specifying the version and --oldpackage option, e.g.
  zypper in --oldpckage kernel-default-5.3.18-lp152.19.2

This kind of problem is sometimes seen on buggy BIOS, and depending on the power-cable plugged or not, etc.  So it might be some casual problem, too.

In anyway, please give hwinfo output, too.
Comment 2 A.Rahman Mahmoud 2020-12-11 14:00:59 UTC
I was on kernel-default-5.3.18-lp152.57.1, I tried kernel-default-5.3.18-lp152.19.2 and it has the same problem.
I may have to clarify that this issue happens almost every time suspend my laptop
hwinfo: 


cpu:                                                            
                       Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz, 1733 MHz
                       Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz, 1959 MHz
                       Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz, 1272 MHz
                       Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz, 1340 MHz
keyboard:
  /dev/input/event0    AT Translated Set 2 keyboard
mouse:
  /dev/input/mice      PS/2 Generic Mouse
  /dev/input/mice      SynPS/2 Synaptics TouchPad
joystick:
  /dev/input/event7    ST LIS3LV02DL Accelerometer
monitor:
                       SAMSUNG LCD Monitor
graphics card:
                       Intel Core Processor Integrated Graphics Controller
sound:
                       Intel 5 Series/3400 Series Chipset High Definition Audio
storage:
                       Floppy disk controller
                       Intel 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
network:
  wlan0                Broadcom BCM4313 802.11bgn Wireless Network Adapter
  eth0                 Intel 82577LC Gigabit Network Connection
network interface:
  lo                   Loopback network interface
  wlan0                WLAN network interface
  eth0                 Ethernet network interface
disk:
  /dev/sda             ST320LT007-9ZV14
partition:
  /dev/sda1            Partition
  /dev/sda2            Partition
  /dev/sda3            Partition
cdrom:
  /dev/sr0             hp DVD RW AD-7721H
usb controller:
                       Intel 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
                       Intel 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
bios:
                       BIOS
bridge:
                       Intel 5 Series/3400 Series Chipset PCI Express Root Port 1
                       Intel HM57 Chipset LPC Interface Controller
                       Intel 1st Generation Core i3/5/7 Processor Reserved
                       Intel 1st Generation Core i3/5/7 Processor QPI Physical 0
                       Intel 5 Series/3400 Series Chipset PCI Express Root Port 4
                       Intel Core Processor QuickPath Architecture Generic Non-core Registers
                       Intel 82801 Mobile PCI Bridge
                       Intel Core Processor DRAM Controller
                       Intel 5 Series/3400 Series Chipset PCI Express Root Port 2
                       Intel 1st Generation Core i3/5/7 Processor Reserved
                       Intel Core Processor QPI Link 0
                       Intel Core Processor QuickPath Architecture System Address Decoder
hub:
                       Intel Integrated Rate Matching Hub
                       Linux Foundation 2.0 root hub
                       Intel Integrated Rate Matching Hub
                       Linux Foundation 2.0 root hub
memory:
                       Main Memory
unknown:
                       FPU
                       DMA controller
                       PIC
                       Keyboard controller
  /dev/lp0             Parallel controller
                       PS/2 Controller
                       Intel 5 Series/3400 Series Chipset HECI Controller
                       Intel 5 Series/3400 Series Chipset Thermal Subsystem
  /dev/ttyS0           16550A
Comment 3 Takashi Iwai 2020-12-11 14:11:03 UTC
Well, I meant to attach the output of hwinfo command to Bugzilla.

And, do I understand correctly that the symptom didn't appear before re-installing Leap 15.2?  If so, what system was on your machine beforehand?
Comment 4 A.Rahman Mahmoud 2020-12-11 14:17:49 UTC
it was leap 15.2 also
Comment 5 Takashi Iwai 2020-12-11 14:38:51 UTC
Hrm, weird.

Could you try the following?

- Try suspend / resume via the direct write to /sys/power/state, 
   # echo -n mem > /sys/power/state

- Change to VT1 via ctrl-alt-F1, login there, and test suspend/resume

- Try to reset the BIOS setup, make sure that the power cable is plugged, then retest.

Also, did you install some system-wide power-saving stuff?
Comment 6 A.Rahman Mahmoud 2020-12-11 15:32:37 UTC
I'm frustrated.
I tried the following

>> - Try suspend / resume via the direct write to /sys/power/state, 
   # echo -n mem > /sys/power/state

I tried this, the same problem

>> - Change to VT1 via ctrl-alt-F1, login there, and test suspend/resume

Tried this too, still nothing

>> - Try to reset the BIOS setup, make sure that the power cable is plugged, then retest.

Unfortunately, no luck with that either

>> Also, did you install some system-wide power-saving stuff?

For this I had tlp.
I uninstalled it, restarted, then tried again and had the same issue
Comment 7 Takashi Iwai 2020-12-11 16:14:04 UTC
(In reply to A.Rahman Mahmoud from comment #6)
> I'm frustrated.

Me, too :)

> I tried the following
> 
> >> - Try suspend / resume via the direct write to /sys/power/state, 
>    # echo -n mem > /sys/power/state
> 
> I tried this, the same problem
> 
> >> - Change to VT1 via ctrl-alt-F1, login there, and test suspend/resume
> 
> Tried this too, still nothing
> 
> >> - Try to reset the BIOS setup, make sure that the power cable is plugged, then retest.
> 
> Unfortunately, no luck with that either
> 
> >> Also, did you install some system-wide power-saving stuff?
> 
> For this I had tlp.
> I uninstalled it, restarted, then tried again and had the same issue

You should avoid tlp package in anyway.  It's known to cause issues on many machines.

We need to get back the state it worked...  As I mentioned, it's often BIOS (ACPI) problem and it's never fixed in the kernel side, as usually the problem goes away suddenly.

But if it's really another kernel issue, maybe it's worth to downgrade to the Leap 15.2 release state before the update.  Or it might be easier to install again but without adding the update repo.
Comment 8 A.Rahman Mahmoud 2020-12-11 16:21:18 UTC
I have this issue for about 3 months since I freshly reinstalled leap 15.2, I think I'm gonna freshly reinstall it again and see what happens
Comment 9 Takashi Iwai 2020-12-11 16:31:14 UTC
Then it's really hard to debug, as we have no reference that worked properly for now.

As another blind shot, you can try the latest upstream kernel from OBS Kernel:stable repo.  It might have been already addressed.
Comment 10 A.Rahman Mahmoud 2020-12-12 12:01:39 UTC
I tried everything I even booted the machine with a windows drive just to reinstall the bios, and I did, and still nothing, I tried a live Debian stable with 4.9 kernel and the issue is there so it's not a kernel issue it's deeper than that but I don't know what.
Comment 11 Takashi Iwai 2020-12-12 12:10:13 UTC
One thing you could try is to a hard reset of BIOS.  You can remove the laptop battery, leave it off for some hours until the small battery for BIOS drains, then boot.  You'll notice that the date is reset.
Comment 12 A.Rahman Mahmoud 2020-12-12 16:06:03 UTC
I've Just tried your idea but in a bit impatient way.
Pulled out the CMOS Battery and discharged the laptop, But still, as you would expect ...
Comment 13 Takashi Iwai 2020-12-13 08:06:01 UTC
Hm, OK, then this might be a different issue from what I've seen in the past.

Currently I have no idea.  You can try Leap 15.1 kernel on top of the 15.2 system and see whether the same problem still happens.  You might need to replace kernel-firmware-* packages with the old kernel-firmware for that, but the rest should work with Leap 15.1 kernel.

If Leap 15.1 is confirmed to work, you can try to narrow down the kernel version showing the regression by trying various kernels in my OBS repo, OBS home:tiwai:kernel:4.13, home:tiwai:kernel:4.14, etc.
Comment 14 A.Rahman Mahmoud 2020-12-18 09:16:32 UTC
Seams like you were right about the BIOS.
I took the laptop's battery off and left it unused for a few days, tried it now and it's working fine,
Thank you for your help, Takashi.
Comment 15 Takashi Iwai 2020-12-18 09:20:23 UTC
Good to hear!
Now let's close the bug.