Bug 1179914 - (CVE-2020-29367) VUL-0: CVE-2020-29367: blosc: heap-based buffer overflow when there is a lack of space to write compressed data
(CVE-2020-29367)
VUL-0: CVE-2020-29367: blosc: heap-based buffer overflow when there is a lack...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.1
Other Other
: P3 - Medium : Critical (vote)
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/272427/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-10 17:43 UTC by Wolfgang Frisch
Modified: 2020-12-30 13:37 UTC (History)
0 users

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 2 OBSbugzilla Bot 2020-12-18 09:00:10 UTC
This is an autogenerated message for OBS integration:
This bug (1179914) was mentioned in
https://build.opensuse.org/request/show/856832 Factory / blosc
Comment 3 OBSbugzilla Bot 2020-12-20 09:00:11 UTC
This is an autogenerated message for OBS integration:
This bug (1179914) was mentioned in
https://build.opensuse.org/request/show/857096 15.1+15.2+Backports:SLE-15-SP1+Backports:SLE-15-SP2 / blosc
Comment 4 Swamp Workflow Management 2020-12-26 23:20:11 UTC
openSUSE-SU-2020:2337-1: An update that solves one vulnerability and has one errata is now available.

Category: security (moderate)
Bug References: 1174075,1179914
CVE References: CVE-2020-29367
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    blosc-1.20.1-lp152.4.3.1
openSUSE Leap 15.1 (src):    blosc-1.20.1-lp151.3.3.1
openSUSE Backports SLE-15-SP2 (src):    blosc-1.20.1-bp152.4.3.1
openSUSE Backports SLE-15-SP1 (src):    blosc-1.20.1-bp151.4.3.1
Comment 5 Wolfgang Frisch 2020-12-30 13:37:28 UTC
Released.