Bug 1177901 - (CVE-2020-15229) VUL-0: CVE-2020-15229: singularity: path traversal and files overwrite with unsquashfs
(CVE-2020-15229)
VUL-0: CVE-2020-15229: singularity: path traversal and files overwrite with u...
Status: NEW
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.1
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Ana Guerrero
Security Team bot
https://smash.suse.de/issue/269188/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-10-19 15:58 UTC by Wolfgang Frisch
Modified: 2021-11-08 14:36 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Frisch 2020-10-19 15:58:53 UTC
CVE-2020-15229

Singularity (an open source container platform) from version 3.1.1 through 3.6.3 has a vulnerability. Due to insecure handling of path traversal and the lack of path sanitization within `unsquashfs`, it is possible to overwrite/create any files on the host filesystem during the extraction with a crafted squashfs filesystem. The extraction occurs automatically for unprivileged (either installation or with `allow setuid = no`) run of Singularity when a user attempt to run an image which is a local SIF image or a single file containing a squashfs filesystem and is coming from remote sources `library://` or `shub://`. Image build is also impacted in a more serious way as it can be used by a root user, allowing an attacker to overwrite/create files leading to a system compromise, so far bootstrap methods `library`, `shub` and `localimage` are triggering the squashfs extraction. This issue is addressed in Singularity 3.6.4. All users are advised to upgrade to 3.6.4 especially if they use Singularity mainly for building image as root user. There is no solid workaround except to temporary avoid to use unprivileged mode with single file images in favor of sandbox images instead. Regarding image build, temporary avoid to build from `library` and `shub` sources and as much as possible use `--fakeroot` or a VM for that.

Upstream references:
https://github.com/hpcng/singularity/security/advisories/GHSA-7gcp-w6ww-2xv9
https://github.com/hpcng/singularity/blob/v3.6.4/CHANGELOG.md#security-related-fixes

Upstream patches:
https://github.com/hpcng/singularity/pull/5611
https://github.com/hpcng/singularity/commit/eba3dea260b117198fdb6faf41f2482ab2f8d53e

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1888811
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-15229
http://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-15229.html
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-15229
Comment 1 Wolfgang Frisch 2020-10-19 16:01:32 UTC
Affected:
openSUSE Leap 15.1
openSUSE Leap 15.2
openSUSE Tumbleweed
Comment 2 OBSbugzilla Bot 2020-10-23 16:50:06 UTC
This is an autogenerated message for OBS integration:
This bug (1177901) was mentioned in
https://build.opensuse.org/request/show/843644 15.1 / singularity
https://build.opensuse.org/request/show/843645 15.2 / singularity
Comment 3 Swamp Workflow Management 2020-10-29 23:25:39 UTC
openSUSE-SU-2020:1770-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1177901
CVE References: CVE-2020-15229
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    singularity-3.6.4-lp152.2.9.1
Comment 4 Swamp Workflow Management 2020-10-29 23:27:40 UTC
openSUSE-SU-2020:1769-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1177901
CVE References: CVE-2020-15229
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    singularity-3.6.4-lp151.2.12.1
Comment 5 Swamp Workflow Management 2020-11-02 05:20:54 UTC
openSUSE-SU-2020:1814-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1177901
CVE References: CVE-2020-15229
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP2 (src):    singularity-3.6.4-bp152.2.12.1