Bug 1176233 - Unable to install nvidia driver 450.66
Unable to install nvidia driver 450.66
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 3rd Party Driver
Current
x86-64 openSUSE Tumbleweed
: P3 - Medium : Critical (vote)
: ---
Assigned To: Stefan Dirsch
Stefan Dirsch
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-09-07 11:31 UTC by Jürgen Fuhrmann
Modified: 2022-06-15 09:33 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
sndirsch: needinfo? (juergen-fuhrmann)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Fuhrmann 2020-09-07 11:31:44 UTC
Hi on a fresh install of tumbleweed (kernel 5.8)
(and btw also on Leap 15.2 with Kernel 5.3) the nvidia driver  450.66 installation fails.

The culprit seems to be that the make system complains about missing scripts/Makefile.kcsan

Trying to report this to nvidia as well...
Comment 1 Jürgen Fuhrmann 2020-09-07 12:21:15 UTC
Reported upstream as well.

https://forums.developer.nvidia.com/t/installation-problem-on-opensuse-tumbleweed-and-15-2/153815


Main error message during install is 
````
/usr/src/linux-5.8.4-1/Makefile:959: scripts/Makefile.kcsan: No such file or directory
make[2]: *** No rule to make target 'scripts/Makefile.kcsan'.  Stop.
make[1]: *** [Makefile:185: __sub-make] Error 2
make: *** [Makefile:81: modules] Error 2
````
Comment 2 Stefan Dirsch 2020-09-07 16:34:19 UTC
Weird. Can't reproduce this here on current kernel of Tumbleweed (also 5.8.4-1). Mabye the G05 package is outdated. Please check this.
Comment 3 Jürgen Fuhrmann 2020-09-07 17:28:48 UTC
All actual, nothing to  do with that.

Your response and this: https://unix.stackexchange.com/a/44167

gave me a hunch.

I had MAKEFLAGS=--no-print-directory -e in my  .profile... and ran zypper from su resp. yast2 from the user session.

I propose to put a hint into the docs saying e.g: "Please ensure to start zypper with a clean environment without user settings changing the behavior of  system tools  like make, grep, ls."


Thanks for the quick reaction and please apologize the trouble...
Comment 4 Stefan Dirsch 2020-09-07 17:39:58 UTC
Ok. Closing as invalid.