Bug 1174291 - [HPC, netcdf] Make environment module name conform to 'industry standard'
[HPC, netcdf] Make environment module name conform to 'industry standard'
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
All All
: P5 - None : Normal (vote)
: ---
Assigned To: Egbert Eich
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-07-20 05:59 UTC by Egbert Eich
Modified: 2022-09-28 12:28 UTC (History)
0 users

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Egbert Eich 2020-07-20 05:59:21 UTC
Currently, the environment module for NetCDF with MPi support is 'pnetcdf'. This is however commonly used for parallel-netcdf - today PnetCDF.
Change this to 'netcdf' regardless if it is built with MPI or not.
Comment 4 Swamp Workflow Management 2020-08-27 19:14:40 UTC
SUSE-RU-2020:2354-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1173598,1174177,1174291
CVE References: 
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for HPC 15-SP2 (src):    netcdf-fortran_4_5_2-gnu-mpich-hpc-4.5.2-6.8.1, netcdf-fortran_4_5_2-gnu-mvapich2-hpc-4.5.2-6.8.1, netcdf-fortran_4_5_2-gnu-openmpi2-hpc-4.5.2-6.8.1, netcdf-fortran_4_5_2-gnu-openmpi3-hpc-4.5.2-6.8.1, netcdf_4_7_3-gnu-hpc-4.7.3-3.4.2, netcdf_4_7_3-gnu-mpich-hpc-4.7.3-3.4.2, netcdf_4_7_3-gnu-mvapich2-hpc-4.7.3-3.4.2, netcdf_4_7_3-gnu-openmpi2-hpc-4.7.3-3.4.2, netcdf_4_7_3-gnu-openmpi3-hpc-4.7.3-3.4.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2020-08-29 04:17:11 UTC
SUSE-RU-2020:2387-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1174291
CVE References: 
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for HPC 15-SP1 (src):    netcdf_4_6_1-gnu-hpc-4.6.1-10.4.1, netcdf_4_6_1-gnu-mpich-hpc-4.6.1-10.4.1, netcdf_4_6_1-gnu-mvapich2-hpc-4.6.1-10.4.1, netcdf_4_6_1-gnu-openmpi2-hpc-4.6.1-10.4.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2020-08-31 10:13:39 UTC
openSUSE-RU-2020:1305-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1173598,1174177,1174291
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    netcdf-fortran_4_5_2-gnu-hpc-4.5.2-lp152.2.3.1, netcdf-fortran_4_5_2-gnu-mpich-hpc-4.5.2-lp152.2.3.1, netcdf-fortran_4_5_2-gnu-mvapich2-hpc-4.5.2-lp152.2.3.1, netcdf-fortran_4_5_2-gnu-openmpi2-hpc-4.5.2-lp152.2.3.1, netcdf-fortran_4_5_2-gnu-openmpi3-hpc-4.5.2-lp152.2.3.1, netcdf_4_7_3-gnu-hpc-4.7.3-lp152.2.3.1, netcdf_4_7_3-gnu-mpich-hpc-4.7.3-lp152.2.3.1, netcdf_4_7_3-gnu-mvapich2-hpc-4.7.3-lp152.2.3.1, netcdf_4_7_3-gnu-openmpi2-hpc-4.7.3-lp152.2.3.1, netcdf_4_7_3-gnu-openmpi3-hpc-4.7.3-lp152.2.3.1
Comment 7 Swamp Workflow Management 2020-09-01 16:24:31 UTC
openSUSE-RU-2020:1316-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1174291
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    netcdf_4_6_1-gnu-hpc-4.6.1-lp151.6.3.1, netcdf_4_6_1-gnu-mpich-hpc-4.6.1-lp151.6.3.1, netcdf_4_6_1-gnu-mvapich2-hpc-4.6.1-lp151.6.3.1, netcdf_4_6_1-gnu-openmpi1-hpc-4.6.1-lp151.6.3.1, netcdf_4_6_1-gnu-openmpi2-hpc-4.6.1-lp151.6.3.1, netcdf_4_6_1-gnu-openmpi3-hpc-4.6.1-lp151.6.3.1
Comment 8 Egbert Eich 2020-09-08 08:24:21 UTC
SLE-12 HPC Module still missing.
Comment 9 Egbert Eich 2020-09-08 10:13:07 UTC
Acutally, there was no fix for SLE-12 HPC. So marking as released.
Comment 10 Swamp Workflow Management 2020-09-15 19:16:53 UTC
openSUSE-RU-2020:1437-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1174291
CVE References: 
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP1 (src):    netcdf_4_6_1-gnu-hpc-4.6.1-bp151.5.3.1, netcdf_4_6_1-gnu-mpich-hpc-4.6.1-bp151.5.3.1, netcdf_4_6_1-gnu-mvapich2-hpc-4.6.1-bp151.5.3.1, netcdf_4_6_1-gnu-openmpi1-hpc-4.6.1-bp151.5.3.1, netcdf_4_6_1-gnu-openmpi2-hpc-4.6.1-bp151.5.3.1, netcdf_4_6_1-gnu-openmpi3-hpc-4.6.1-bp151.5.3.1
Comment 11 Swamp Workflow Management 2020-09-16 13:18:59 UTC
SUSE-RU-2020:2643-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1173598,1174177,1174291
CVE References: 
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for HPC 15-SP1 (src):    netcdf-fortran_4_4_4-gnu-mpich-hpc-4.4.4-9.6.1, netcdf-fortran_4_4_4-gnu-openmpi2-hpc-4.4.4-9.6.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 13 Swamp Workflow Management 2020-10-27 11:14:44 UTC
openSUSE-RU-2020:1751-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1173598,1174177,1174291
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    netcdf-4.6.1-lp151.6.6.1, netcdf-fortran_4_4_4-gnu-hpc-4.4.4-lp151.9.3.1, netcdf-fortran_4_4_4-gnu-mpich-hpc-4.4.4-lp151.9.3.1, netcdf-fortran_4_4_4-gnu-openmpi1-hpc-4.4.4-lp151.9.3.1, netcdf-fortran_4_4_4-gnu-openmpi2-hpc-4.4.4-lp151.9.3.1, netcdf-fortran_4_4_4-gnu-openmpi3-hpc-4.4.4-lp151.9.3.1, netcdf-openmpi-4.6.1-lp151.6.6.1, netcdf_4_6_1-gnu-hpc-4.6.1-lp151.6.6.1, netcdf_4_6_1-gnu-mpich-hpc-4.6.1-lp151.6.6.1, netcdf_4_6_1-gnu-mvapich2-hpc-4.6.1-lp151.6.6.1, netcdf_4_6_1-gnu-openmpi1-hpc-4.6.1-lp151.6.6.1, netcdf_4_6_1-gnu-openmpi2-hpc-4.6.1-lp151.6.6.1, netcdf_4_6_1-gnu-openmpi3-hpc-4.6.1-lp151.6.6.1
Comment 14 Swamp Workflow Management 2020-10-30 17:14:42 UTC
openSUSE-RU-2020:1775-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1174291
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    netcdf_4_6_1-gnu-hpc-4.6.1-lp151.6.9.1, netcdf_4_6_1-gnu-mpich-hpc-4.6.1-lp151.6.9.1, netcdf_4_6_1-gnu-mvapich2-hpc-4.6.1-lp151.6.9.1, netcdf_4_6_1-gnu-openmpi1-hpc-4.6.1-lp151.6.9.1, netcdf_4_6_1-gnu-openmpi2-hpc-4.6.1-lp151.6.9.1, netcdf_4_6_1-gnu-openmpi3-hpc-4.6.1-lp151.6.9.1
Comment 15 Swamp Workflow Management 2020-10-30 23:17:58 UTC
openSUSE-RU-2020:1779-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1173598,1174177,1174291
CVE References: 
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP1 (src):    netcdf-4.6.1-bp151.5.6.1, netcdf-openmpi-4.6.1-bp151.5.6.1, netcdf_4_6_1-gnu-hpc-4.6.1-bp151.5.6.1, netcdf_4_6_1-gnu-mpich-hpc-4.6.1-bp151.5.6.1, netcdf_4_6_1-gnu-mvapich2-hpc-4.6.1-bp151.5.6.1, netcdf_4_6_1-gnu-openmpi1-hpc-4.6.1-bp151.5.6.1, netcdf_4_6_1-gnu-openmpi2-hpc-4.6.1-bp151.5.6.1, netcdf_4_6_1-gnu-openmpi3-hpc-4.6.1-bp151.5.6.1
Comment 16 Swamp Workflow Management 2021-01-19 23:15:46 UTC
openSUSE-RU-2021:0120-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1174291
CVE References: 
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP1 (src):    netcdf_4_6_1-gnu-hpc-4.6.1-bp151.5.9.2, netcdf_4_6_1-gnu-mpich-hpc-4.6.1-bp151.5.9.2, netcdf_4_6_1-gnu-mvapich2-hpc-4.6.1-bp151.5.9.2, netcdf_4_6_1-gnu-openmpi1-hpc-4.6.1-bp151.5.9.3, netcdf_4_6_1-gnu-openmpi2-hpc-4.6.1-bp151.5.9.2, netcdf_4_6_1-gnu-openmpi3-hpc-4.6.1-bp151.5.9.2