Bug 1173720 - No sound after upgrade from Leap 15.1
No sound after upgrade from Leap 15.1
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Sound
Leap 15.2
x86-64 SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: Takashi Iwai
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-07-04 19:37 UTC by Alberto Zacchetti
Modified: 2022-06-17 05:46 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Output of alsa-info.sh (60.87 KB, text/plain)
2020-07-10 14:01 UTC, Alberto Zacchetti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto Zacchetti 2020-07-04 19:37:37 UTC
After upgrading from Leap 15.1 to Leap 15.2, the system no longer plays any sound (even from Yast sound setting) although the snd-hda-intel driver appears to be loaded. The chipset is a C600/X79 and it worked wonderfully on Leap 15.1. Now in Yast I see all the volume controls, but I don't hear any sound on headphones. Also in KDE the only item that appears is the digital output (which I can't verify) while every other analog output has disappeared.
Comment 1 Alberto Zacchetti 2020-07-04 20:34:52 UTC
I also tried to launch the live version of Leap 15.2 (KDE) with the same results. So it is not an error in the transition from the previous release.
Comment 2 Alberto Zacchetti 2020-07-05 06:57:52 UTC
lspci -nnk | grep -A2 Audio

00:1b.0 Audio device [0403]: Intel Corporation C600/X79 series chipset High Definition Audio Controller [8086:1d20] (rev 06)
        Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:d735]
        Kernel driver in use: snd_hda_intel
--
03:00.1 Audio device [0403]: NVIDIA Corporation GK107 HDMI Audio Controller [10de:0e1b] (rev a1)
        Subsystem: CardExpert Technology Device [10b0:0fc6]
        Kernel driver in use: snd_hda_intel

lsmod | grep snd

snd_hda_codec_realtek   131072  1
snd_hda_codec_generic    94208  1 snd_hda_codec_realtek
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_codec_hdmi     73728  1
snd_hda_intel          53248  3
snd_hda_codec         163840  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core          110592  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               155648  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              40960  1 snd_pcm
snd                   106496  14 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm
soundcore              16384  1 snd

aplay -L

null
    Discard all samples (playback) or generate zero samples (capture)
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=PCH
    HDA Intel PCH, ALC892 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    Front speakers
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=1
    HDA NVidia, HDMI 1
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=2
    HDA NVidia, HDMI 2
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 3
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=4
    HDA NVidia, HDMI 4
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=5
    HDA NVidia, HDMI 5
    HDMI Audio Output

With the speaker-test command I can listen to the sound through headphones and adjust the volume with the Yast controls, but in Yast the button to test the sound does not give any output. It looks like a configuration problem, but I don't know where to take action.
Comment 3 Alberto Zacchetti 2020-07-06 07:57:49 UTC
The problem concerns pulseaudio and not the drivers, as I initially thought. I modified the configuration in /etc/pulse/default.pa by uncommenting a couple of lines (as indicated by the arrows) and now pulse also recognizes the headphones and the sound works, but it seems very slow to initialize itself and in the graphic controls (KDE). Anyone have any idea how I could better modify the configuration to restore smooth and correct operation?


/etc/pulse/default.pa

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
load-module module-alsa-sink                    <-----
load-module module-alsa-source device=hw:1,0    <-----
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
Comment 4 Takashi Iwai 2020-07-09 10:55:24 UTC
Hrm, not sure what went wrong in your case.  I'd rather try to remove the stale config (align /etc/pulse/* from the distro default and remove ~/.pulse* and ~/.config/pulse* directories), and re-run "setup-pulseaudio --enable" once.
Comment 5 Alberto Zacchetti 2020-07-09 14:14:50 UTC
I did the test you suggested, but nothing has changed. But I have done other research and tests and I have found that it is the detection of the audio jacks. So I modified the following file: /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf (see below the content with the two commented lines indicated by arrows) and the audio headphones have turn back to appear in the drop-down menu and now they work perfectly. However, their connection is not detected and therefore they are always active even if disconnected. I guess the same goes for all other analog outputs, however I think there should be a way to automatically correct this jack setting, without changing all the files by hand.

[General]
priority = 99
description-key = analog-output-headphones

[Properties]
device.icon_name = audio-headphones

[Jack Dock Headphone]
required-any = any

[Jack Dock Headphone Phantom]
required-any = any
state.plugged = unknown
state.unplugged = unknown

[Jack Front Headphone]
#required-any = any                <---

[Jack Front Headphone Phantom]
required-any = any
state.plugged = unknown
state.unplugged = unknown

[Jack Headphone]
#required-any = any                <---

[Jack Headphone Phantom]
required-any = any
state.plugged = unknown
state.unplugged = unknown

# This jack can be either a headphone *or* a mic. Used on some ASUS netbooks.
[Jack Headphone Mic]
required-any = any

[Element Hardware Master]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Master]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Master Mono]
switch = off
volume = off

[Element Speaker+LO]
switch = off
volume = off

[Element Headphone+LO]
required-any = any
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Headphone]
required-any = any
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Headset]
required-any = any
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Line HP Swap]
switch = on
required-any = any

; This profile path is intended to control the first headphones, not
; the second headphones. But it should not hurt if we leave the second
; headphone jack enabled nonetheless.
[Element Headphone2]
switch = mute
volume = zero

[Element Speaker]
switch = off
volume = off

[Element Desktop Speaker]
switch = off
volume = off

; On some machines Front is actually a part of the Headphone path
[Element Front]
switch = mute
volume = zero

[Element Rear]
switch = off
volume = off

[Element Surround]
switch = off
volume = off

[Element Side]
switch = off
volume = off

[Element Center]
switch = off
volume = off

[Element LFE]
switch = off
volume = off

[Element Bass Speaker]
switch = off
volume = off

[Element Speaker Front]
switch = off
volume = off

[Element Speaker Surround]
switch = off
volume = off

[Element Speaker Side]
switch = off
volume = off

[Element Speaker CLFE]
switch = off
volume = off

.include analog-output.conf.common
Comment 6 Takashi Iwai 2020-07-10 12:58:23 UTC
Then it might be rather because of some kernel driver issue, just surfaced on the recent PA.

Please give alsa-info.sh output.  Run it with --no-upload option and attach (no paste) to Bugzilla.
Comment 7 Alberto Zacchetti 2020-07-10 14:01:18 UTC
Created attachment 839583 [details]
Output of alsa-info.sh

Ok, I ran the command alsa-info.sh and attached the output.
Comment 8 Zhon Zely 2020-10-02 21:30:48 UTC
Friends do not insist more than this and pulseaudio they will not fix it. They don't care about those little ones. It worked perfect and in one go in version 15.0 and 15.1. You have to wait for 15.2 to see if it is solved by a miracle.
Comment 9 Ben Guy 2022-06-16 11:36:10 UTC
Hmm, i guess that depends on the 'little ones' being Leap as opposed to Tumbleweed ?
Because Tumbleweed is what i am one - so as a rolling release, i can prepared to put up with immediate
changed that can cause disruptions, bugs etc etc...But....I expect all leap users to be priority No 1
for any/all bugs - as your the 'stable' release

My Internal Motherboard Intel GPU HDMI no longer exists as far as kde plasma's audio settings are concerned
Hope this gets fixed for both out sakes :)
Comment 10 Takashi Iwai 2022-06-17 05:46:18 UTC
Erm this has been forgotten as NEEDINFO flag wasn't cleared.

Leap 15.2 was already discontinued.  Please create a new entry if the problem is still seen on Leap 15.3 (at best test with Leap 15.4).
If it's seen on TW, create another bug, too.

Thanks.