Bug 1173595 - (CVE-2020-14983) VUL-0: CVE-2020-14983: chocolate-doom: malicious user can overwrite the server's stack leads to DoS
(CVE-2020-14983)
VUL-0: CVE-2020-14983: chocolate-doom: malicious user can overwrite the serve...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.1
Other Other
: P3 - Medium : Major (vote)
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/262159/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-07-01 15:28 UTC by Alexandros Toptsoglou
Modified: 2020-07-14 14:19 UTC (History)
0 users

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandros Toptsoglou 2020-07-01 15:28:43 UTC
CVE-2020-14983

The server in Chocolate Doom 3.0.0 and Crispy Doom 5.8.0 doesn't validate the user-controlled num_players value, leading to a buffer overflow. A malicious user can overwrite the server's stack.

References:
https://github.com/chocolate-doom/chocolate-doom/issues/1293

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1852412
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-14983
http://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-14983.html
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14983
https://github.com/chocolate-doom/chocolate-doom/issues/1293
Comment 1 Alexandros Toptsoglou 2020-07-01 15:33:11 UTC
Leap 15.1, 15.2 and Factory are affected. The fix is available at [1]. Please upgrade Factory to the latest version that is 3.0.1. 

[1] https://github.com/chocolate-doom/chocolate-doom/commit/f1a8d991aa8a14afcb605cf2f65cd15fda204c56
Comment 2 OBSbugzilla Bot 2020-07-01 19:20:07 UTC
This is an autogenerated message for OBS integration:
This bug (1173595) was mentioned in
https://build.opensuse.org/request/show/818162 15.1 / chocolate-doom
https://build.opensuse.org/request/show/818163 15.2 / chocolate-doom
Comment 3 Swamp Workflow Management 2020-07-05 16:12:34 UTC
openSUSE-SU-2020:0928-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1173595
CVE References: CVE-2020-14983
Sources used:
openSUSE Leap 15.1 (src):    chocolate-doom-3.0.1-lp151.3.3.1
Comment 4 Swamp Workflow Management 2020-07-07 04:13:24 UTC
openSUSE-SU-2020:0939-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1173595
CVE References: CVE-2020-14983
Sources used:
openSUSE Leap 15.2 (src):    chocolate-doom-3.0.1-lp152.4.3.1
Comment 5 Swamp Workflow Management 2020-07-08 19:12:13 UTC
openSUSE-SU-2020:0947-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1173595
CVE References: CVE-2020-14983
Sources used:
openSUSE Backports SLE-15-SP1 (src):    chocolate-doom-3.0.1-bp151.4.3.1
Comment 6 Alexandros Toptsoglou 2020-07-14 14:19:46 UTC
Done