Bug 1173071 - Kernel 5.7.1 does not boot
Kernel 5.7.1 does not boot
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-06-17 12:36 UTC by Bernhard Donaubauer
Modified: 2020-10-19 08:05 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (bdonauba)


Attachments
last words of Kernel 5.7.1 (4.55 MB, image/jpeg)
2020-06-17 12:36 UTC, Bernhard Donaubauer
Details
konsole log (1.17 MB, image/jpeg)
2020-06-18 13:55 UTC, Bernhard Donaubauer
Details
full hwinfo (891.63 KB, text/plain)
2020-06-18 14:36 UTC, Bernhard Donaubauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Donaubauer 2020-06-17 12:36:19 UTC
Created attachment 838888 [details]
last words of Kernel 5.7.1

With the last tumbleweed update came Kernel 5.7.1. Unfortunately it does not boot on my system. I attached a photo of the "last words" at boot because journalctl --boot=-1 gives me the log of the last successful boot.
Comment 1 Takashi Iwai 2020-06-17 13:29:10 UTC
Is it with Intel WiFi?  If yes, there is a known regression up to 5.7.1 (boo#1172905).
Comment 2 Bernhard Donaubauer 2020-06-18 08:07:36 UTC
I have a Realtek WLAN adapter:

brix:~ # hwinfo --wlan
05: PCI 200.0: 0282 WLAN controller                             
  [Created at pci.386]
  Unique ID: qru8.ycgOQWahtiF
  Parent ID: hoOk.6Tao18MXOcC
  SysFS ID: /devices/pci0000:00/0000:00:1c.2/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8821 "RTL8821AE 802.11ac PCIe Wireless Network Adapter"
  SubVendor: pci 0x1a3b "AzureWave"
  SubDevice: pci 0x2161 
  Driver: "rtl8821ae"
  Driver Modules: "rtl8821ae"
Comment 3 Takashi Iwai 2020-06-18 08:39:58 UTC
OK, then it's a different problem.

Does the old 5.6.y kernel still boot fine?  If yes, please give the full hwinfo output.

Also, when you boot without quiet and splash=silent options, it might show more logs.
Comment 4 Bernhard Donaubauer 2020-06-18 13:40:21 UTC
I'm running on 5.6.14-1-default at the moment.

hwinfo --short:
==============

cpu:                                                            
                       Intel(R) Core(TM) i5-4570R CPU @ 2.70GHz, 1895 MHz
                       Intel(R) Core(TM) i5-4570R CPU @ 2.70GHz, 1846 MHz
                       Intel(R) Core(TM) i5-4570R CPU @ 2.70GHz, 1909 MHz
                       Intel(R) Core(TM) i5-4570R CPU @ 2.70GHz, 1990 MHz
keyboard:
                       Logitech Unifying Receiver
  /dev/input/event9    MosArt 2.4G Keyboard Mouse
mouse:
                       Logitech Unifying Receiver
  /dev/input/mice      MosArt 2.4G Keyboard Mouse
monitor:
                       HQ272PPB
graphics card:
                       Intel VGA compatible controller
sound:
                       Intel 8 Series/C220 Series Chipset High Definition Audio Controller
                       Intel Crystal Well HD Audio Controller
storage:
                       Intel 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode]
network:
  enp3s0               Gigabyte Onboard Ethernet
  wlp2s0               Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
network interface:
  enp3s0               Ethernet network interface
  wlp2s0               Ethernet network interface
  lo                   Loopback network interface
disk:
  /dev/sdf             Generic MS/MS-Pro/HG
  /dev/sdd             Generic SM/xD-Picture
  /dev/sdb             Samsung SSD 850
  /dev/sde             Generic SDXC/MMC
  /dev/sdc             Generic Compact Flash
  /dev/sda             Intenso SSD SATA
partition:
  /dev/sdb1            Partition
  /dev/sdb2            Partition
  /dev/sdb3            Partition
  /dev/sda1            Partition
usb controller:
                       Intel 8 Series/C220 Series Chipset Family USB EHCI #2
                       Intel 8 Series/C220 Series Chipset Family USB EHCI #1
                       Intel 8 Series/C220 Series Chipset Family USB xHCI
bios:
                       BIOS
bridge:
                       Intel 8 Series/C220 Series Chipset Family PCI Express Root Port #1
                       Intel HM87 Express LPC Controller
                       Intel 8 Series/C220 Series Chipset Family PCI Express Root Port #4
                       Intel Crystal Well DRAM Controller
                       Intel 8 Series/C220 Series Chipset Family PCI Express Root Port #3
hub:
                       VIA VL812 Hub
                       Intel Hub
                       Linux Foundation 2.0 root hub
                       Linux Foundation 3.0 root hub
                       Linux Foundation 2.0 root hub
                       VIA VL812 Hub
                       VIA VL812 Hub
                       Intel Hub
                       Linux Foundation 2.0 root hub
                       VIA VL812 Hub
memory:
                       Main Memory
bluetooth:
                       IMC Networks Bluetooth Radio
unknown:
                       FPU
                       DMA controller
                       PIC
                       Keyboard controller
                       PS/2 Controller
                       Intel 8 Series/C220 Series Chipset Family MEI Controller #1
                       Intel 8 Series/C220 Series Chipset Family SMBus Controller
Comment 5 Bernhard Donaubauer 2020-06-18 13:54:33 UTC
Booted 5.7.1 without quiet and splash.

Made a photo of the last lines and attached it.
Comment 6 Bernhard Donaubauer 2020-06-18 13:55:19 UTC
Created attachment 838940 [details]
konsole log
Comment 7 Takashi Iwai 2020-06-18 14:25:26 UTC
(In reply to Bernhard Donaubauer from comment #4)
> hwinfo --short:

Could you run hwinfo without option, and upload the full contents to Bugzilla (use attachment, not pasting to the form)?
Comment 8 Takashi Iwai 2020-06-18 14:26:59 UTC
And try to pass "nomodeset" boot option.  This will stop switching to the native Intel graphics and keeps EFI framebuffer.  If it's a problem in i915 driver, this should make the system booting further.
Comment 9 Bernhard Donaubauer 2020-06-18 14:36:14 UTC
attached full hwinfo
Comment 10 Bernhard Donaubauer 2020-06-18 14:36:38 UTC
Created attachment 838943 [details]
full hwinfo
Comment 11 Bernhard Donaubauer 2020-06-22 19:48:14 UTC
Excuse me I'm late. I've just tested the nomodeset option and I succeeded. With nomodeset 5.7.1-1-default is bootable.
Comment 12 Takashi Iwai 2020-06-23 06:31:56 UTC
Thanks, that's at least a good step forward, we could narrow the range.

Could you try the latest kernel in OBS Kernel:stable repo?  It contains the newer 5.7.x kernel, and a bug might have been already addressed.

If the problem persists, we need to report it to the upstream devs.
Comment 13 Bernhard Donaubauer 2020-06-23 19:21:29 UTC
The problem persists with 5.7.2-1.2 and 5.7.4-2.1.g23bad63 from https://download.opensuse.org/repositories/Kernel:/stable/standard/x86_64/.
Comment 14 Takashi Iwai 2020-06-25 14:44:18 UTC
OK, then it's time to report to upstream.
The upstream bug tracker is on gitlab.freedesktop.org
  https://gitlab.freedesktop.org/drm/intel

Open an issue ticket there.
Comment 15 Miroslav Beneš 2020-10-16 12:39:12 UTC
Bernhard, have you opened the ticket upstream? Could you provide a link, please?

TW also got 5.8.x kernel meanwhile, so it would be nice to know if it improved things.
Comment 16 Bernhard Donaubauer 2020-10-19 07:17:45 UTC
I'm sorry I can't check the problem anymore because my Tumbleweed crashed and I changed to CentOs.

I did not open a ticket upstream.
Comment 17 Miroslav Beneš 2020-10-19 08:05:00 UTC
Pity, but thanks for letting us know. Closing.