Bug 1172334 - After switching bluetooth off it doesn't turn back on with the gnome interface
After switching bluetooth off it doesn't turn back on with the gnome interface
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
x86-64 Other
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks: 1172335
  Show dependency treegraph
 
Reported: 2020-06-01 03:30 UTC by Ryan Bach
Modified: 2020-06-04 02:06 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Bach 2020-06-01 03:30:28 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:76.0) Gecko/20100101 Firefox/76.0
Build Identifier: 

Gnome 3 is bugged if it doesn't turn back on

Reproducible: Always

Steps to Reproduce:
1. Use the right menu with power/etc
2. CLick turn off Bluetooth
3. Click turn on (and it doesn't turn on...)
Actual Results:  
Doesn't turn on

Expected Results:  
Should turn on

Latest tumbleweed
Comment 1 Ryan Bach 2020-06-01 05:11:45 UTC
upsteam bug:
https://gitlab.gnome.org/GNOME/gnome-bluetooth/-/issues/38
Comment 2 Ryan Bach 2020-06-02 00:47:41 UTC
53: USB 00.2: 0000 Unclassified device
[Created at usb.122]
Unique ID: 2B3P.5usWtnvfTL2
Parent ID: FZIx.7qWCOCfUJwE
SysFS ID: /devices/pci0000:00/0000:00:12.0/usb8/8-2/8-2:1.2
SysFS BusID: 8-2:1.2
Hardware Class: unknown
Model: "Broadcom BCM20702A0 Bluetooth 4.0"
Hotplug: USB
Vendor: usb 0x0a5c "Broadcom Corp."
Device: usb 0x21e8 "BCM20702A0 Bluetooth 4.0"
Revision: "1.12"
Serial ID: "5CF3706B57C1"
Driver: "btusb"
Driver Modules: "btusb"
Speed: 12 Mbps
Module Alias: "usb:v0A5Cp21E8d0112dcFFdsc01dp01icFFiscFFipFFin02"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #69 (Hub)
Comment 3 Jonathan Kang 2020-06-02 07:01:27 UTC
Do you have a Wi-Fi adapter available in your system? If not, turning off
bluetooth means turning on aeroplane more. You'll have to turn off the aeroplane
mode to turn on bluetooth.

This seems to be the design pattern upstream choosed.
Comment 4 Ryan Bach 2020-06-03 00:35:40 UTC
Yes, I have a USB adapter.
Comment 5 Jonathan Kang 2020-06-03 08:57:08 UTC
(In reply to Ryan Bach from comment #4)
> Yes, I have a USB adapter.

Is it turned off when you turn off bluetooth?
Comment 6 Ryan Bach 2020-06-03 17:07:49 UTC
(In reply to Jonathan Kang from comment #5)
> (In reply to Ryan Bach from comment #4)
> > Yes, I have a USB adapter.
> 
> Is it turned off when you turn off bluetooth?

How do I check that from command line?
Comment 7 Jonathan Kang 2020-06-04 01:47:43 UTC
(In reply to Ryan Bach from comment #6)
> (In reply to Jonathan Kang from comment #5)
> > (In reply to Ryan Bach from comment #4)
> > > Yes, I have a USB adapter.
> > 
> > Is it turned off when you turn off bluetooth?
> 
> How do I check that from command line?

You can see that in the top right popup menu. The output of `journalctl -f`
when you trying to turn on bluetooth will be helpful.
Comment 8 Ryan Bach 2020-06-04 02:06:10 UTC
It is working now. Thanks for the help.