Bug 1171360 - Shutter package is broken due to missing dependency in Tumbleweed
Shutter package is broken due to missing dependency in Tumbleweed
Status: RESOLVED DUPLICATE of bug 929755
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 Applications
Current
Other openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Matthias Mailänder
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-05-07 12:11 UTC by jean-christophe baptiste
Modified: 2020-05-07 16:15 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jean-christophe baptiste 2020-05-07 12:11:32 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.129 Safari/537.36
Build Identifier: 

The package is broken as perl(Gnome2) package is missing in Tumbleweed repositories.

Please fix this dependency or remove Shutter from Tumbleweed.

Reproducible: Always
Comment 1 Andreas Stieger 2020-05-07 13:33:47 UTC
dup of bug 929755

*** This bug has been marked as a duplicate of bug 929755 ***
Comment 2 Andreas Stieger 2020-05-07 13:35:27 UTC
(In reply to jean-christophe baptiste from comment #0)
> Please fix this dependency or remove Shutter from Tumbleweed.

Shutter is not in Tumbleweed.
Comment 3 jean-christophe baptiste 2020-05-07 13:40:35 UTC
What do you mean?

It is:

❯ sudo zypper info shutter
Chargement des données du dépôt...
Lecture des paquets installés...


Informations sur paquet shutter :
---------------------------------
Dépôt                     : Dépôt principal (OSS)
Nom                       : shutter
Version                   : 0.94-1.9
Architecture              : noarch
Fabricant                 : openSUSE
Taille une fois installé  : 13,5 MiB
Installé                  : Non
État                      : non installé
Paquet source             : shutter-0.94-1.9.src
Résumé                    : Featureful screenshot tool
Description               : 
    Shutter is a GTK+ 2.0 screenshot application written in perl.
    Shutter covers all features of common command line tools like
    scrot or import and adds reasonable new features combined
    with a comfortable GUI using the GTK+ 2.0 framework
Comment 4 Andreas Stieger 2020-05-07 13:45:00 UTC
By that I mean that it was dropped form Factory 5 years ago:

$ osc log -D openSUSE:Factory/shutter | head
----------------------------------------------------------------------------
r16 | dimstar_suse | 2015-05-11 15:25:05 | 951c6c0b94dbd403b65bbb6d2404265d | 0.93.1 | rq306322

Remove from Factory - uninstallable since the removal of perl-Gnome2
----------------------------------------------------------------------------

https://build.opensuse.org/request/show/306322
Comment 5 jean-christophe baptiste 2020-05-07 14:52:34 UTC
Sorry but why does it show up in the repo then?
Comment 6 Andreas Stieger 2020-05-07 15:42:55 UTC
Tumbleweed release managers never wiped the binary.
Comment 7 jean-christophe baptiste 2020-05-07 16:08:16 UTC
Can't this issue be addressed to them then?

It's bad to keep broken packages.