Bug 1171097 - binutils fail in :A staging with gcc9
binutils fail in :A staging with gcc9
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-05-04 14:19 UTC by Martin Liška
Modified: 2020-05-05 09:16 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2020-05-04 14:19:45 UTC
the only change in Staging:A is the change of %_libexecdir to be /usr/libexec instead of /usr/lib:

[  199s] during IPA pass: inline
[  199s] ../../gold/compressed_output.cc:342:1: internal compiler error: Segmentation fault

https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:A/binutils/standard/i586
Comment 1 Martin Liška 2020-05-04 14:21:26 UTC
Fails due to:

GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072
Compiler executable checksum: 00000000000000000000000000000000
==4195== Use of uninitialised value of size 4
==4195==    at 0x8C7C658: function_summary<ipa_node_params*>::is_ggc() (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195==    by 0x900C053: function_summary<ipa_node_params*>::symtab_removal(cgraph_node*, void*) (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195==    by 0x8BA2600: cgraph_node::remove() (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195==    by 0x8F45705: inline_call(cgraph_edge*, bool, vec<cgraph_edge*, va_heap, vl_ptr>*, int*, bool, bool*) (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195==    by 0x8F3E3D0: ??? (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195==    by 0x9102AA4: ??? (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195==    by 0x8CEB261: execute_one_pass(opt_pass*) (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195==    by 0x9031719: execute_ipa_pass_list(opt_pass*) (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195==    by 0x8FCB967: symbol_table::compile() (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195==    by 0x8FCB5CA: symbol_table::finalize_compilation_unit() (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195==    by 0x9040BFA: ??? (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195==    by 0x8A6E5A9: toplev::main(int, char**) (in /usr/lib/gcc/i586-suse-linux/9/cc1plus)
==4195== 
during IPA pass: inline
../../gold/common.cc:364:1: internal compiler error: Segmentation fault
  364 | } // End namespace gold.
      | ^
Comment 2 Martin Liška 2020-05-04 14:28:57 UTC
Likely caused by some mixes binaries from different packages. I would wipe the project.
Comment 3 Martin Liška 2020-05-05 09:16:25 UTC
It was a OBS bootstrap issue, it's fixed now.