Bug 1171044 - Incomplete list of alsa audio inputs
Incomplete list of alsa audio inputs
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Sound
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Takashi Iwai
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-05-04 08:53 UTC by Konstantin Voinov
Modified: 2020-05-12 14:27 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
alsa-info.txt (134.09 KB, text/plain)
2020-05-06 12:27 UTC, Konstantin Voinov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Voinov 2020-05-04 08:53:14 UTC
Hi,

The system is TW 20200501

alsa-1.2.2-2.1
kernel-default-5.6.6-1.1

I have Echo Gina 3G soundcard. With one of recent update (unfortunately this system is not on btrfs) it cannot be used as sound input with some apps, especially with JUCE-apps, like Tracktion Waveform. I guess these apps relies on naming aliases of subinterfaces, so how it look before update:

part of arecord -L

sysdefault:CARD=Gina3G
    Gina3G, Gina3G
    Default Audio Device
front:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    Front speakers
rear:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    Rear speakers
center_lfe:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    Center and Subwoofer speakers
side:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    Side speakers
surround21:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    IEC958 (S/PDIF) Digital Audio Output

How it looks now:

part of arecord -L

default:CARD=Gina3G
    Gina3G, Gina3G
    Default Audio Device
sysdefault:CARD=Gina3G
    Gina3G, Gina3G
    Default Audio Device
rear:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    Rear speakers
center_lfe:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    Center and Subwoofer speakers
side:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    Side speakers
usbstream:CARD=Gina3G
    Gina3G
    USB Stream Output

Card has two inputs which were bind to the:

front:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    Front speakers

Now this section is absent. Though card works fine, and it possible to select input via alsa API.

For workaround I've put

defaults.namehint.extended on

into .asoundrc so it's possible to use inputs named as:

hw:CARD=Gina3G,DEV=0
    Gina3G, Gina3G
    Direct hardware device without any conversions

I didn't look into alsa changes deeply. But, is it expected behavior and users should reconfigure that part manually now?
Comment 1 Takashi Iwai 2020-05-06 11:02:42 UTC
This looks like a regression in the recent fix in alsa-lib.
Need to investigate now...
Comment 2 Takashi Iwai 2020-05-06 11:41:54 UTC
Could you try whether alsa and libasound2 packages in OBS home:tiwai:branches:multimedia:libs/alsa repo restores the old behavior?
It's a blind shot, so it might be not hitting, but worth to try.
Comment 3 Konstantin Voinov 2020-05-06 12:08:25 UTC
Thanks. Tried just now, but the same result.

i+ | alsa                         | пакет | 1.2.2-323.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-debugsource             | пакет | 1.2.2-323.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-devel                   | пакет | 1.2.2-323.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-devel-32bit             | пакет | 1.2.2-323.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-firmware                | пакет | 1.2.1-2.1   | noarch      | openSUSE-20160405-0
i+ | alsa-firmware                | пакет | 1.2.1-2.1   | noarch      | openSUSE:Factory
i+ | alsa-firmware                | пакет | 1.2.1-2.1   | noarch      | openSUSE:Tumbleweed
i+ | alsa-oss                     | пакет | 1.1.8-2.2   | x86_64      | openSUSE-20160405-0
i+ | alsa-oss                     | пакет | 1.1.8-2.2   | x86_64      | openSUSE:Factory
i+ | alsa-oss                     | пакет | 1.1.8-2.2   | x86_64      | openSUSE:Tumbleweed
i+ | alsa-oss-32bit               | пакет | 1.1.8-2.2   | x86_64      | openSUSE-20160405-0
i+ | alsa-oss-32bit               | пакет | 1.1.8-2.2   | x86_64      | openSUSE:Factory
i+ | alsa-oss-32bit               | пакет | 1.1.8-2.2   | x86_64      | openSUSE:Tumbleweed
i+ | alsa-plugins                 | пакет | 1.2.2-154.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-plugins-32bit           | пакет | 1.2.2-154.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-plugins-debugsource     | пакет | 1.2.2-154.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-plugins-jack            | пакет | 1.2.2-154.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-plugins-jack-32bit      | пакет | 1.2.2-154.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-plugins-pulse           | пакет | 1.2.2-154.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-plugins-pulse-32bit     | пакет | 1.2.2-154.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-plugins-pulse-debuginfo | пакет | 1.2.2-154.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-ucm-conf                | пакет | 1.2.2-13.1  | noarch      | Branch project for package alsa (openSUSE_Tumbleweed)
i+ | alsa-utils                   | пакет | 1.2.2-205.1 | x86_64      | Branch project for package alsa (openSUSE_Tumbleweed)


kv@Kot:~> arecord -L|grep -i front
kv@Kot:~>
Comment 4 Takashi Iwai 2020-05-06 12:21:56 UTC
Could you give alsa-info.sh output?  Run the script with --no-upload option and attach the output to Bugzilla.
Comment 5 Konstantin Voinov 2020-05-06 12:27:13 UTC
Created attachment 837467 [details]
alsa-info.txt

sure
Comment 6 Takashi Iwai 2020-05-06 12:54:17 UTC
Hrm, I'm trying to reproduce the issue but I can't here.

Do you have any own setup in ~/.asoundrc or else?
It does look to me as if defaults.namehint.basic is set off.
Comment 7 Takashi Iwai 2020-05-06 13:21:41 UTC
Maybe it's another commit.  Let's try the another shot.
Could you retest with the package in OBS home:tiwai:branches:multimedia:libs/alsa again?  (The revision 324, which should be published soon later)
Comment 8 Takashi Iwai 2020-05-06 13:54:40 UTC
Ah wait.  You're checking the input direction, arecord -L, *not* the output aplay -L?  That explains.

The recent fixes changed front and iec958 to be output-only.  I guess this is a bad move as applications depend on "front" capture as well.  (Basically iec958 could be also captured, so it's no output-only, either.)
Comment 9 Takashi Iwai 2020-05-06 14:18:10 UTC
The revision 326 in my OBS home:tiwai:branches:multimedia:libs/alsa repo should contain the revert of the problematic change.  Please check it later.
Comment 10 Konstantin Voinov 2020-05-07 00:53:58 UTC
>>The recent fixes changed front and iec958 to be output-only.  I guess this is a bad move as applications depend on "front" capture as well.  (Basically iec958 could be also captured, so it's no output-only, either.)

>>The revision 326 in my OBS home:tiwai:branches:multimedia:libs/alsa repo should contain the revert of the problematic change.


That's it. All fine now.
Comment 11 Takashi Iwai 2020-05-12 14:16:25 UTC
The upstream also addressed the regression.  I'll backport the upstream fix later, but so far we can live with the temporary revert.  Let's close now.
Comment 12 Konstantin Voinov 2020-05-12 14:27:21 UTC
Thank You Takashi san!