Bug 1170941 - no wifi with kernel 5.6.6 in tw snapshot 20200425
no wifi with kernel 5.6.6 in tw snapshot 20200425
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 openSUSE Factory
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-30 15:16 UTC by Stephen Berman
Modified: 2020-04-30 20:17 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
hwinfo (2.06 MB, text/plain)
2020-04-30 15:58 UTC, Stephen Berman
Details
dmesg_5.6.4 (70.87 KB, text/plain)
2020-04-30 15:59 UTC, Stephen Berman
Details
dmesg_5.6.6 (70.66 KB, text/plain)
2020-04-30 16:00 UTC, Stephen Berman
Details
modules (7.63 KB, text/plain)
2020-04-30 16:36 UTC, Stephen Berman
Details
hwinfo_5.6.4 (2.07 MB, text/plain)
2020-04-30 16:37 UTC, Stephen Berman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Berman 2020-04-30 15:16:07 UTC
On booting Tumbleweed after updating to snapshot 20200425 the Network Manager shows no connection. When I open the Connection Systems Settings Module and click on my configured wifi access point, a PolicyKit dialog pops up requesting authorization with the root password. I enter the password and nothing happens, and the wifi remains unconnected.  This is with kernel 5.6.6-1-default.  When I reboot and choose kernel 5.6.4 from the Grub menu, on logging on the wifi connection is there and active, as usual.  So this seems to be a regression in 5.6.6.  This is with a Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter.
Comment 1 Takashi Iwai 2020-04-30 15:38:00 UTC
Could you give hwinfo output?  Also give dmesg output after the boot on both working and non-working kernels, too.  Thanks.
Comment 2 Takashi Iwai 2020-04-30 15:43:56 UTC
Also try the kernel in OBS Kernel:stable repo, if you don't use Secure Boot.
  http://download.opensuse.org/repositories/Kernel:/stable/standard/
Comment 3 Stephen Berman 2020-04-30 15:58:53 UTC
Created attachment 837213 [details]
hwinfo
Comment 4 Stephen Berman 2020-04-30 15:59:44 UTC
Created attachment 837214 [details]
dmesg_5.6.4
Comment 5 Stephen Berman 2020-04-30 16:00:12 UTC
Created attachment 837215 [details]
dmesg_5.6.6
Comment 6 Stephen Berman 2020-04-30 16:02:08 UTC
(In reply to Takashi Iwai from comment #2)
> Also try the kernel in OBS Kernel:stable repo, if you don't use Secure Boot.
>   http://download.opensuse.org/repositories/Kernel:/stable/standard/

I'll try it when I have more time, hopefully on the weekend.
Comment 7 Takashi Iwai 2020-04-30 16:17:45 UTC
Which kernel module are you using?  It looks like the downstream driver, judging from hwinfo output.
Comment 8 Takashi Iwai 2020-04-30 16:19:32 UTC
One more favor: could you take hwinfo output from the working, 5.6.4 kernel, too?
Comment 9 Stephen Berman 2020-04-30 16:36:33 UTC
Created attachment 837218 [details]
modules
Comment 10 Stephen Berman 2020-04-30 16:37:38 UTC
Created attachment 837219 [details]
hwinfo_5.6.4
Comment 11 Stephen Berman 2020-04-30 16:41:37 UTC
(In reply to Takashi Iwai from comment #7)
> Which kernel module are you using?  It looks like the downstream driver,
> judging from hwinfo output.

I've attached the sorted output of lsmod.  I believe the module for the wifi is from the rtl8821ce-kmp-default package from obs://build.opensuse.org/home:Sauerland
Comment 12 Takashi Iwai 2020-04-30 16:49:52 UTC
OK, then you'd need the KMP built to the corresponding target (Kernel_stable), I suppose.
Comment 13 Stephen Berman 2020-04-30 18:05:25 UTC
(In reply to Takashi Iwai from comment #12)
> OK, then you'd need the KMP built to the corresponding target
> (Kernel_stable), I suppose.

Hm, so far every time I've done zypper dup and there was a new kernel, that module has also been updated.  Maybe this time it wasn't or it was buggy.... 
Ah, just checked and there's a new module available, now running zypper dup...
it's removing the 5.6.6_1-2.17 version of the module and installing 1-2.18...
Update finished... rebooting with 5.6.6... and the wifi connection is back! So I guess the previous module was buggy but it's now fixed.  So you can close this bug.  Thanks for the feedback.
Comment 14 Takashi Iwai 2020-04-30 20:17:49 UTC
Good to hear that you managed to work.  Let's close now.