Bug 1170849 - config.{guess,sub} are updated if aarch64/ppc64le/riscv64 support is missing, but it breaks for cargo/rust packaging
config.{guess,sub} are updated if aarch64/ppc64le/riscv64 support is missing,...
Status: RESOLVED FIXED
: 1175502 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
aarch64 All
: P5 - None : Normal (vote)
: ---
Assigned To: Michael Schröder
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-29 15:24 UTC by Guillaume GARDET
Modified: 2021-10-19 09:14 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Script proposal to handle '.cargo-checksum.json' files (907 bytes, text/plain)
2020-04-29 15:24 UTC, Guillaume GARDET
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume GARDET 2020-04-29 15:24:48 UTC
Created attachment 837103 [details]
Script proposal to handle '.cargo-checksum.json' files

To build packages in OBS, config.{guess,sub} are updated if aarch64/ppc64le/riscv64 supports are missing in the file.
It works properly for most packages, but with packages using cargo/rust, it breaks, because checksums are used to verify the files.
So, packages like bat, rav1e, and more are broken on aarch64 (and ppc64le and riscv64).

So, we need to update the script that update config.{guess,sub} to handle '.cargo-checksum.json' files.

In attachment, I added a script to handle '.cargo-checksum.json' files.
Comment 1 Guillaume GARDET 2020-04-29 16:34:31 UTC
SR to devel project: https://build.opensuse.org/request/show/798982

Tested successfully with 'rav1e' package.
Comment 2 Dirk Mueller 2020-04-30 12:18:42 UTC
I think we should only autopatch files that look lik ethey're created from autotools. the cargo package files are most likely not autotools ones?
Comment 3 Fabian Vogt 2020-04-30 12:39:35 UTC
(In reply to Dirk Mueller from comment #2)
> I think we should only autopatch files that look lik ethey're created from
> autotools.

It checks for "config-patches" first, which is part of

> # Please send patches to <config-patches@gnu.org>.

> the cargo package files are most likely not autotools ones?

It bundles libbacktrace sources.

It still does a unnecessary replacement here though, as aarch64 is supported by this specific config.*. The missing riscv64- triggers it apparently.
Comment 4 OBSbugzilla Bot 2020-05-15 07:40:11 UTC
This is an autogenerated message for OBS integration:
This bug (1170849) was mentioned in
https://build.opensuse.org/request/show/805744 Factory / rpm
Comment 5 OBSbugzilla Bot 2020-05-19 08:00:15 UTC
This is an autogenerated message for OBS integration:
This bug (1170849) was mentioned in
https://build.opensuse.org/request/show/807119 Factory / rpm
Comment 6 OBSbugzilla Bot 2020-06-26 10:10:11 UTC
This is an autogenerated message for OBS integration:
This bug (1170849) was mentioned in
https://build.opensuse.org/request/show/817222 Factory / rpm
Comment 7 Michael Vetter 2020-08-26 13:26:05 UTC
*** Bug 1175502 has been marked as a duplicate of this bug. ***
Comment 8 Guillaume GARDET 2021-10-19 09:14:54 UTC
Set as fixed since the files are updated only if the current arch is missing, which should be ok now for aarch64.