Bug 1170844 - wget shows glib warning after gnome 3.36 update
wget shows glib warning after gnome 3.36 update
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-29 15:07 UTC by Paolo Stivanin
Modified: 2020-05-04 06:42 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Stivanin 2020-04-29 15:07:16 UTC
Since the last update that brought GNOME 3.36, wget is showing some glib warnings when called:

$ wget http://foo

(process:32425): GLib-GObject-WARNING **: 17:05:27.759: ../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x5582d16eb430' of type 'GSettings'

(process:32425): GLib-GObject-WARNING **: 17:05:27.759: ../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x5582d16ebc80' of type 'GSettings'

(process:32425): GLib-GObject-WARNING **: 17:05:27.759: ../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x5582d16ebdc0' of type 'GSettings'

(process:32425): GLib-GObject-WARNING **: 17:05:27.759: ../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x5582d16eb700' of type 'GSettings'

(process:32425): GLib-GObject-WARNING **: 17:05:27.759: ../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x5582d16eb5c0' of type 'GSettings'
--2020-04-29 17:05:27--  http://foo/
Resolving foo (foo)... failed: Name or service not known.
wget: unable to resolve host address ‘foo’
Comment 1 Timo Jyrinki 2020-04-30 06:41:31 UTC
(process:6661): GLib-GObject-WARNING **: 09:38:52.396: ../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x558e70ce7430' of type 'GSettings'

...

6661  execve("/bin/sh", ["sh", "-c", "/usr/lib/libproxy-0.4.15/pxgsett"...], 0x7ffcdda89b60 /* 100 vars */ <unfinished ...>

...

So related to /usr/lib/libproxy-0.4.15/pxgsettings ?
Comment 2 Paolo Stivanin 2020-04-30 06:53:27 UTC
My strace output:

read(3, 
(process:9700): GLib-GObject-WARNING **: 08:51:15.692: ../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x5620f6fc0430' of type 'GSettings'
"org.gnome.system.proxy/ignore-ho"..., 4096) = 62

(process:9700): GLib-GObject-WARNING **: 08:51:15.692: ../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x5620f6fc0c80' of type 'GSettings'
read(3, "org.gnome.system.proxy/use-same-"..., 4096) = 168
fcntl(3, F_SETFL, O_RDONLY|O_NONBLOCK)  = 0
stat("/usr/lib64/libproxy-0.4.15/modules/network_networkmanager.so", 
(process:9700): GLib-GObject-WARNING **: 08:51:15.692: ../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x5620f6fc0dc0' of type 'GSettings'
{st_mode=S_IFREG|0755, st_size=14720, ...}) = 0
openat(AT_FDCWD, "/usr/lib64/libproxy-0.4.15/modules/network_networkmanager.so", O_RDONLY|O_CLOEXEC) = 4
read(4, 
(process:9700): GLib-GObject-WARNING **: 08:51:15.692: ../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x5620f6fc0700' of type 'GSettings'
"\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0 \21\0\0\0\0\0\0"..., 832) = 832
fstat(4, 
(process:9700): GLib-GObject-WARNING **: 08:51:15.692: ../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x5620f6fc05c0' of type 'GSettings'
{st_mode=S_IFREG|0755, st_size=14720, ...}) = 0
Comment 3 Paolo Stivanin 2020-05-04 06:42:33 UTC
problem is gone with latest updates, closing this