Bug 1170836 - GCC 10: guile build fails on i586
GCC 10: guile build fails on i586
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Martin Liška
E-mail List
:
Depends on:
Blocks: 1157217
  Show dependency treegraph
 
Reported: 2020-04-29 14:05 UTC by Martin Liška
Modified: 2020-05-06 07:15 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2020-04-29 14:05:53 UTC
Fails here:
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:N/guile/standard/i586

with:
[ 3155s] warning: call to primitive-fork while multiple threads are running;
[ 3155s]          further behavior unspecified.  See "Processes" in the
[ 3155s]          manual, for more information.
[ 3155s] warning: call to primitive-fork while multiple threads are running;
[ 3155s]          further behavior unspecified.  See "Processes" in the
[ 3155s]          manual, for more information.
[ 3155s] ;;; SSAX warning: Skipping PI: xml
[ 3155s] 
[ 3155s] ;;; SSAX warning: Skipping PI: PI
[ 3155s] 
[ 3155s] ;;; SSAX warning: Skipping PI: PI1
[ 3155s] 
[ 3155s] ;;; SSAX warning: (
[ 3155s]  Warning:  DOCTYPE DECL  T   system1  found and skipped)
[ 3155s] ;;; SSAX warning: (
[ 3155s]  Warning:  Internal DTD subset is not currently handled )
[ 3155s] ;;; SSAX warning: (
[ 3155s]  Warning:  DOCTYPE DECL  T   system1  found and skipped)
[ 3155s] ;;; SSAX warning: Skipping PI: pi
[ 3155s] 
[ 3155s] ;;; SSAX warning: DOCTYPE DECL T system1 found and skipped
[ 3155s] WARNING: (test-suite sxml-xpath): imported module (sxml xpath) overrides core binding `filter'
[ 3155s] FAIL: check-guile
Comment 1 Martin Liška 2020-05-05 08:31:26 UTC
@Peter, Jonathan: Can you please take a look?
Comment 2 Martin Liška 2020-05-05 09:00:13 UTC
Following fails

grep '^FAIL' ./check-guile.log
FAIL: numbers.test: Number-theoretic division: euclidean/: mixed types: (130.0 10/7)
FAIL: numbers.test: Number-theoretic division: euclidean/: mixed types: (130.0 -10/7)
FAIL: numbers.test: Number-theoretic division: floor/: mixed types: (130.0 10/7)
FAIL: numbers.test: Number-theoretic division: floor/: mixed types: (-130.0 -10/7)
FAIL: numbers.test: Number-theoretic division: ceiling/: mixed types: (130.0 -10/7)
FAIL: numbers.test: Number-theoretic division: ceiling/: mixed types: (-130.0 10/7)
FAIL: numbers.test: Number-theoretic division: truncate/: mixed types: (130.0 10/7)
FAIL: numbers.test: Number-theoretic division: truncate/: mixed types: (130.0 -10/7)
FAIL: numbers.test: Number-theoretic division: truncate/: mixed types: (-130.0 10/7)
FAIL: numbers.test: Number-theoretic division: truncate/: mixed types: (-130.0 -10/7)

I bet it's caused by x87 floating-point unit and it's extended precision.
Comment 3 Martin Liška 2020-05-05 09:05:41 UTC
I'll disable the tests.
Comment 4 Martin Liška 2020-05-05 09:21:40 UTC
I've just made SR#800310.
Comment 5 Martin Liška 2020-05-06 07:15:03 UTC
Fixed in devel project.