Bug 1170588 - [Build 20200425] GNote is not initialized with sample notes on first start
[Build 20200425] GNote is not initialized with sample notes on first start
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
https://openqa.opensuse.org/tests/124...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-27 12:58 UTC by Dominique Leuenberger
Modified: 2020-05-11 14:08 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2020-04-27 12:58:15 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-desktopapps-documentation-x11@64bit fails in
[gnote_first_run](https://openqa.opensuse.org/tests/1246918/modules/gnote_first_run/steps/18)

gnote used to create notes from templates; those are no longer there


## Test suite description



## Reproducible

Fails since (at least) Build [20200423](https://openqa.opensuse.org/tests/1245340)


## Expected result

Last good: [20200422](https://openqa.opensuse.org/tests/1243443) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=desktopapps-documentation-x11&version=Tumbleweed)
Comment 1 Dominique Leuenberger 2020-04-28 17:38:33 UTC
Upstream report: https://gitlab.gnome.org/GNOME/gnote/-/issues/36
Comment 3 Dominique Leuenberger 2020-05-05 19:34:16 UTC
Upstream commited a fix for this issue; backported into our GNOME:Factory package
Comment 4 Bruce Rogers 2020-05-07 22:23:00 UTC
(In reply to Dominique Leuenberger from comment #3)
> Upstream commited a fix for this issue; backported into our GNOME:Factory
> package

I don't know enough about how gnote works to know if this change caused it, but after installing the most recent gnote available as part of the Tumbleweed update today, I no longer see any of my notes. I built a gnote without this latest patch added, but that still doesn't see them - perhaps the damage is already done.
I have a whole lot of notes stored in gnote and really want them available again. I see where they are still stored under ~/.local/share/gnote, so it seems bizzare that they are not found. Instead gnote acts like it needs to newly initialize, which this bug seems to be addressing in part.

I add this report to this bug because it seems related to this change.
Comment 5 Dominique Leuenberger 2020-05-11 13:16:38 UTC
Thanks for the report Bruce - Seems GNote 3.36.1 is addressing this as well and fixing the issue.

the easiest to test / verify:

osc getbinaries GNOME:Next gnote openSUSE_Factory x86_64
sudo rpm -Fhv binaries/*.rpm

Can you please pre-validate it? It's already en route to Tumbleweed too, but that will be two days or so.
Comment 6 Bruce Rogers 2020-05-11 13:54:37 UTC
(In reply to Dominique Leuenberger from comment #5)
> Thanks for the report Bruce - Seems GNote 3.36.1 is addressing this as well
> and fixing the issue.
> 
> the easiest to test / verify:
> 
> osc getbinaries GNOME:Next gnote openSUSE_Factory x86_64
> sudo rpm -Fhv binaries/*.rpm
> 
> Can you please pre-validate it? It's already en route to Tumbleweed too, but
> that will be two days or so.

This update does indeed resolve this problem for me. I now see and can edit my old notes. I see the new notes created while experimenting as well, but can delete those - all seems to be working normally again.
Thanks for helping with this.
Comment 7 Dominique Leuenberger 2020-05-11 14:08:07 UTC
Indeed; I'd seen the two templates messages being duplicates as well; but I doubt it can reasonably be auto-cleaned up. So removing the manually will be the best way indeed.

But at least we are back to:
* On first start, the two default notes are generated
* On subsequent starts, all existing notes are shown and can be opened