Bug 1170586 - opensuse_welcome screen broken with GNOME 3.36 Wayland
opensuse_welcome screen broken with GNOME 3.36 Wayland
Status: RESOLVED DUPLICATE of bug 1169203
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
aarch64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-27 12:37 UTC by Guillaume GARDET
Modified: 2020-05-05 13:17 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume GARDET 2020-04-27 12:37:00 UTC
Since aarch64 Snapshot 20200423 where GNOME has been updated to version 3.36, GNOME Wayland tests fail in openQA due to opensuse_welcome app not showed properly.
Depending on tests:
* the window is sometime shown briefly (but mostly black) and close itself: https://openqa.opensuse.org/tests/1245138#step/opensuse_welcome/2
* or you can see 'Welcome' in upper task bar, but no window: https://openqa.opensuse.org/tests/1246456#step/opensuse_welcome/1

If I exclude opensuse_welcome test in create_hdd_gnome, chained tests sometime show the opensuse_welcome application started on boot. https://openqa.opensuse.org/tests/1246713#step/boot_to_desktop/2

I tried to double the timeout with TIMEOUT_SCALE, but it did not improve.

There is no such problem with GNOME X11, or other Desktops.
Comment 1 Fabian Vogt 2020-05-04 15:58:05 UTC
This is reproducible after logging out and in again, but running "opensuse-welcome" manually works fine. So this seems to be some race condition on session start, maybe involving Xwayland?
Comment 2 Sergio Lindo Mansilla 2020-05-05 13:17:46 UTC
Duplicate of bsc#1169203

*** This bug has been marked as a duplicate of bug 1169203 ***