Bug 1170501 - Intel Skylake: intel(0): sna_mode_shutdown_crtc: invalid state found on pipe 0, disabling CRTC:51
Intel Skylake: intel(0): sna_mode_shutdown_crtc: invalid state found on pipe ...
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 SUSE Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-25 10:37 UTC by Dmitry Bot
Modified: 2021-02-16 22:12 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Bot 2020-04-25 10:37:09 UTC
Sometimes i have black screen after login from wake-up:
Close and open notebook lib resolved problem.

In /var/log/Xorg.0.log i see error:

intel(0): sna_mode_shutdown_crtc: invalid state found on pipe 0, disabling CRTC:51

That happened sometimes.

uname -r
5.6.4-1-default

00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07) (prog-if 00 [VGA controller])
	DeviceName:  Onboard IGD
	Subsystem: Dell Latitude E7470
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 127

ll /etc/X11/xorg.conf.d/
total 20
-rw-r--r-- 1 root root 311 Sep  2  2019 00-keyboard.conf
-rw-r--r-- 1 root root 489 Apr 20 11:30 10-libvnc.conf
-rw-r--r-- 1 root root 529 Jul  1  2011 50-device.conf
-rw-r--r-- 1 root root 527 Jul  1  2011 50-monitor.conf
-rw-r--r-- 1 root root 491 Jul  1  2011 50-screen.conf

cat /etc/X11/xorg.conf.d/50-screen.conf 
# Having multiple "Screen" sections is known to be problematic. Make
# sure you don't have in use another one laying around e.g. in another
# xorg.conf.d file or even a generic xorg.conf file. More details can
# be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
#
#Section "Screen"
#  Identifier "Default Screen"
#
#  Device "Default Device"
#
#  ## Doesn't help for radeon/radeonhd drivers; use magic in
#  ## 50-device.conf instead
#  Monitor "Default Monitor"
#
#EndSection

cat /etc/X11/xorg.conf.d/50-monitor.conf 
# Having multiple "Monitor" sections is known to be problematic. Make
# sure you don't have in use another one laying around e.g. in another
# xorg.conf.d file or even a generic xorg.conf file. More details can
# be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
#
#Section "Monitor"
#  Identifier "Default Monitor"
#
#  ## If your monitor doesn't support DDC you may override the
#  ## defaults here
#  #HorizSync 28-85
#  #VertRefresh 50-100
#
#  ## Add your mode lines here, use e.g the cvt tool
#
#EndSection
Comment 1 Stefan Dirsch 2020-04-25 10:44:33 UTC
Hmm. Is this also reprroducable when using modeset driver instead? Uninstall xf86-video-intel package and restart your Xsession for this.
Comment 2 Dmitry Bot 2020-04-25 13:39:56 UTC
After remove xf86-video-intel package:

[  1949.510] (EE) modeset(0): present flip failed
[  1949.550] (WW) modeset(0): flip queue failed: Invalid argument
[  1949.550] (WW) modeset(0): Page flip failed: Invalid argument
[  1949.550] (EE) modeset(0): present flip failed
[  1949.590] (WW) modeset(0): flip queue failed: Invalid argument
[  1949.590] (WW) modeset(0): Page flip failed: Invalid argument
[  1949.590] (EE) modeset(0): present flip failed
[  1949.629] (WW) modeset(0): flip queue failed: Invalid argument
[  1949.629] (WW) modeset(0): Page flip failed: Invalid argument


and many artifacts...
Comment 3 Dmitry Bot 2020-04-27 08:17:54 UTC
I add config file /etc/X11/xorg.conf.d/20-modesetting.conf

with

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "modesetting"
    Option      "AccelMethod"    "glamor"
    Option      "DRI"            "3"
EndSection

and there are no more artifacts.

I will watch how notebook wake-up...
Comment 4 Stefan Dirsch 2020-04-27 10:26:40 UTC
Sounds weird. glamor should have been the deafult. I'm not aware of a "DRI" option of the modesetting driver, but maybe it isn't documented in the manual page ...
Comment 5 Dmitry Bot 2020-05-01 12:46:35 UTC
Now its same...
1069.311] (WW) modeset(0): flip queue failed: Invalid argument
[  1069.311] (WW) modeset(0): Page flip failed: Invalid argument
[  1069.311] (EE) modeset(0): present flip failed
[  1069.350] (WW) modeset(0): flip queue failed: Invalid argument
[  1069.351] (WW) modeset(0): Page flip failed: Invalid argument
[  1069.351] (EE) modeset(0): present flip failed
[  1069.375] (WW) modeset(0): flip queue failed: Invalid argument
[  1069.375] (WW) modeset(0): Page flip failed: Invalid argument
[  1069.375] (EE) modeset(0): present flip failed
[  1069.391] (WW) modeset(0): flip queue failed: Invalid argument
[  1069.391] (WW) modeset(0): Page flip failed: Invalid argument
[  1069.391] (EE) modeset(0): present flip failed
[  1069.430] (WW) modeset(0): flip queue failed: Invalid argument
[  1069.430] (WW) modeset(0): Page flip failed: Invalid argument
[  1069.430] (EE) modeset(0): present flip failed
Comment 6 Stefan Dirsch 2020-05-01 15:15:19 UTC
(In reply to Dmitry Bot from comment #5)
> Now its same...
> 1069.311] (WW) modeset(0): flip queue failed: Invalid argument
> [  1069.311] (WW) modeset(0): Page flip failed: Invalid argument
> [  1069.311] (EE) modeset(0): present flip failed
> [  1069.350] (WW) modeset(0): flip queue failed: Invalid argument
> [  1069.351] (WW) modeset(0): Page flip failed: Invalid argument
> [  1069.351] (EE) modeset(0): present flip failed
> [  1069.375] (WW) modeset(0): flip queue failed: Invalid argument
> [  1069.375] (WW) modeset(0): Page flip failed: Invalid argument
> [  1069.375] (EE) modeset(0): present flip failed
> [  1069.391] (WW) modeset(0): flip queue failed: Invalid argument
> [  1069.391] (WW) modeset(0): Page flip failed: Invalid argument
> [  1069.391] (EE) modeset(0): present flip failed
> [  1069.430] (WW) modeset(0): flip queue failed: Invalid argument
> [  1069.430] (WW) modeset(0): Page flip failed: Invalid argument
> [  1069.430] (EE) modeset(0): present flip failed

Same as which setting? So which setting does now behave as which other setting?
Comment 7 Dmitry Bot 2020-05-01 18:33:19 UTC
Section "Device"
    Identifier  "Intel Graphics"
    Driver      "modesetting"
    Option      "AccelMethod"    "glamor"
    Option      "DRI"            "3"
EndSection

and

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "modesetting"
EndSection
Comment 8 Stefan Dirsch 2020-05-01 20:29:45 UTC
Now I'm completely confused. :-(
Comment 9 Dmitry Bot 2020-05-06 06:07:35 UTC
Its happened sametimes...
and what does it depend i dont know
Comment 10 Stefan Dirsch 2020-05-06 06:45:06 UTC
Oh. You mean you see the same issues with Intel and modesetting driver? This would mean that it's related to the Kernel driver (KMS).

It could be a regression in the kernel of Tumbleweed. It may have been fixed already in our KOTD.

https://en.opensuse.org/openSUSE:Kernel_of_the_day
Comment 12 Dmitry Bot 2020-06-04 19:15:24 UTC
So...
After month usage this error repeated only when:

- Charger disconnected and laptop working from battery;
- Close lib and laptop goes to sleep;
- Connect charger;
- Open lib and login in XFCE ->> black screen;
- Close lib and open - lighting screen.
- And in Xorg.0.log I see only error:

(EE) intel(0): sna_mode_shutdown_crtc: invalid state found on pipe 0, disabling CRTC:51

And yes,I see the same issues with Intel and modesetting driver.
Comment 13 Stefan Dirsch 2020-08-30 09:31:28 UTC
Hmm. Does this still happen with the latest kernel 5.8.0 on Tumbleweed? Just update TW ...
Comment 14 Dmitry Bot 2020-08-30 11:11:09 UTC
Yes, its happened too with kernel 5.8.2-1-default:

cat /var/log/Xorg.0.log | grep EE
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    17.415] (II) Initializing extension MIT-SCREEN-SAVER
[   167.627] (EE) intel(0): sna_mode_shutdown_crtc: invalid state found on pipe 0, disabling CRTC:51

cat /etc/X11/xorg.conf.d/20-intel.conf 
Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
#        Option      "AccelMethod"  "uxa"
	Option "TearFree" "true"
    EndSection
Comment 15 Dmitry Bot 2020-08-30 11:19:17 UTC
The same with modesetting:

cat 20-modesetting.conf 
Section "Device"
    Identifier  "Intel Graphics"
    Driver      "modesetting"
    Option      "AccelMethod"     "glamor"
    Option      "DRI"             "3"
EndSection
Comment 16 Stefan Dirsch 2020-08-30 13:03:58 UTC
Ok. Thanks for giving it a try!
Comment 17 Stefan Dirsch 2020-11-04 03:56:18 UTC
Kernel 5.9.1 is available in latest TW. Could you give it another try?
Comment 18 Dmitry Bot 2020-11-05 06:39:37 UTC
Unfortunately I can't, the laptop is sold...
Comment 19 Stefan Dirsch 2020-11-05 10:04:35 UTC
Ok. BTW, I'm using a laptop with Skylake with kernel 5.6.0-rc6-1.g5c2f002-default

  Model: "Intel HD Graphics 620"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x5916 "HD Graphics 620"
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x2245 
  Revision: 0x02
Comment 20 Stefan Dirsch 2020-12-09 12:56:07 UTC
Let's better reassign this to kernel component.
Comment 21 Stefan Dirsch 2021-02-16 22:12:36 UTC
Let's close this one since the reporter no longer can provide any feedback for this issue.