Bug 1170466 - [Build 20200417] openQA test fails in select_patterns - Missing package grub2-powerpc-ieee1275 on NET install media
[Build 20200417] openQA test fails in select_patterns - Missing package grub2...
Status: RESOLVED FIXED
: 1164312 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Patterns
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Michael Matz
E-mail List
https://openqa.opensuse.org/tests/124...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-24 14:39 UTC by Sergio Lindo Mansilla
Modified: 2020-05-26 07:57 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio Lindo Mansilla 2020-04-24 14:39:24 UTC
Reproducible in scenario opensuse-Tumbleweed-NET-ppc64-install_minimalx@ppc64
https://openqa.opensuse.org/tests/1240973/modules/select_patterns/steps/8

Fails since Build 20200220


Always latest result in this scenario: https://openqa.opensuse.org/tests/latest?arch=ppc64&distri=opensuse&flavor=NET&machine=ppc64&test=install_minimalx&version=Tumbleweed
Comment 1 Dominique Leuenberger 2020-05-18 08:37:24 UTC
Grub2 for PPC is unresolvable:

unresolvable: nothing provides gcc9-32bit needed by gcc-32bit
Comment 2 Dominique Leuenberger 2020-05-18 08:37:49 UTC
(In reply to Dominique Leuenberger from comment #1)
> Grub2 for PPC is unresolvable:
> 
> unresolvable: nothing provides gcc9-32bit needed by gcc-32bit

See https://build.opensuse.org/package/show/openSUSE:Factory:PowerPC/grub2
Comment 3 Richard Biener 2020-05-18 09:06:42 UTC
Digging a bit into the link I find this is actually ppc64le, correct?  For
ppc64le there is no 32bit flavor and there should not be any gcc-32bit package
either.  For ppc64 (not -le) there should be both unless we define
%disable_32bit (though %disable_32bit is not honored by the gcc symlink package).

I see, in openSUSE:Factory:PowerPC

%ifarch ppc64
Macros:
%disable_32bit 1
:Macros
%endif

not sure if that's new since Build 20200220.

I'll take the bug for 'gcc' but grub2 should not require gcc-32bit on ppc64
since it will vanish as well so the bug is really with grub2 or the project
setup.
Comment 4 Dominique Leuenberger 2020-05-18 09:20:54 UTC
(In reply to Richard Biener from comment #3)
> Digging a bit into the link I find this is actually ppc64le, correct?

No, this bug is about ppc64 (be) - the ppc64le tests seem to be ok

> For ppc64le there is no 32bit flavor and there should not be any gcc-32bit
> package
> either.  For ppc64 (not -le) there should be both unless we define
> %disable_32bit (though %disable_32bit is not honored by the gcc symlink
> package).
> 
> I see, in openSUSE:Factory:PowerPC
> 
> %ifarch ppc64
> Macros:
> %disable_32bit 1
> :Macros
> %endif
> 
> not sure if that's new since Build 20200220.

Close-by; was probably the first rebuild of gcc after that change:

 299 (k0da         2017-06-19 09:19:30    62) Macros:
1357 (Andreas_Schwab 2020-01-12 10:50:06    63) %disable_32bit 1
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
 299 (k0da         2017-06-19 09:19:30    64) :Macros
 299 (k0da         2017-06-19 09:19:30    65) %endif

> I'll take the bug for 'gcc' but grub2 should not require gcc-32bit on ppc64
> since it will vanish as well so the bug is really with grub2 or the project
> setup.

So either Andreas_Schwab to have -32bit disabled - or Michael Chang for grub2 requiring -32bit on ppc64
Comment 5 Andreas Schwab 2020-05-18 09:29:55 UTC
 299 (k0da         2017-06-19 09:19:30    68) %ifarch ppc64
 299 (k0da         2017-06-19 09:19:30    69) Macros:
 299 (k0da         2017-06-19 09:19:30    70) %define disable_32bit 1
 299 (k0da         2017-06-19 09:19:30    71) :Macros
 299 (k0da         2017-06-19 09:19:30    72) %endif
Comment 6 OBSbugzilla Bot 2020-05-19 07:40:06 UTC
This is an autogenerated message for OBS integration:
This bug (1170466) was mentioned in
https://build.opensuse.org/request/show/806858 Factory / gcc
Comment 7 Dominique Leuenberger 2020-05-21 09:43:34 UTC
Just documenting that grub2 currently builds again for ppc - we'll see what openQA returns when a snapshot becomes testable

Relevant changes done:

osc log openSUSE:Factory:PowerPC _project
>r1451 | Andreas_Schwab | 2020-05-08 19:31:26 | 26cd75fe2351b20220241a4fc3121917 | None | 
>
><no message>

osc rdiff openSUSE:Factory:PowerPC _project -r1455:1456
>Index: _config
>===================================================================
>--- _config (revision 1455)
>+++ _config (revision 1456)
>@@ -58,12 +58,6 @@
> Prefer: mozilla-nss-certs
> 
> %define ghc_arches ppc ppc64 ppc64le
>-%ifarch ppc64
>-Macros:
>-%disable_32bit 1
>-:Macros
>-%endif
>-
> Macros:
> %power64 ppc64 ppc64p7 ppc64le
> %ghc_arches ppc ppc64 ppc64le
Comment 8 Michel Normand 2020-05-22 05:20:12 UTC
*** Bug 1164312 has been marked as a duplicate of this bug. ***
Comment 9 Michel Normand 2020-05-26 07:57:59 UTC
no more failure for TW 20200523.