Bug 1170418 - nothing provides python2-rpm needed by rpmdevtools
nothing provides python2-rpm needed by rpmdevtools
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Martin Pluskal
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-24 09:06 UTC by Jordi Massaguer
Modified: 2020-04-26 07:15 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jordi Massaguer 2020-04-24 09:06:16 UTC
When running this command

zypper -n in rpm-build rpmdevtools createrepo libcreaterepo_c-devel

I got this error

Retrieving repository 'openSUSE-Tumbleweed-Non-Oss' metadata [....done]
Building repository 'openSUSE-Tumbleweed-Non-Oss' cache [....done]
Retrieving repository 'openSUSE-Tumbleweed-Oss' metadata [...............done]
Building repository 'openSUSE-Tumbleweed-Oss' cache [....done]
Retrieving repository 'openSUSE-Tumbleweed-Update' metadata [.....done]
Building repository 'openSUSE-Tumbleweed-Update' cache [....done]
All repositories have been refreshed.
Loading repository data...
Reading installed packages...
'createrepo' not found in package names. Trying capabilities.
Resolving package dependencies...

Problem: nothing provides python2-rpm needed by rpmdevtools-8.10-5.1.noarch
 Solution 1: do not install rpmdevtools-8.10-5.1.noarch
 Solution 2: break rpmdevtools-8.10-5.1.noarch by ignoring some of its dependencies
Comment 1 Martin Pluskal 2020-04-26 07:15:31 UTC
As part of dropping of python2, python2-rpm has been dropped, meanwhile rpmdevtools were updated to work with python3 - see 
https://build.opensuse.org/request/show/797599