Bug 1170224 - No sound card list in yast2-sound
No sound card list in yast2-sound
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Minor (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-22 13:47 UTC by Libor Pechacek
Modified: 2020-09-25 01:55 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
hack to make generate_soundcard_db.rb work again (823 bytes, patch)
2020-04-22 13:47 UTC, Libor Pechacek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Libor Pechacek 2020-04-22 13:47:05 UTC
Created attachment 836454 [details]
hack to make generate_soundcard_db.rb work again

The sound card database embedded into yast2-sound is empty on Tumbleweed. As a result, the "add new sound card" dialog does not offer any cards for addition. The root cause is a failed run of generate_soundcard_db.rb during package build, where the script fails to locate sound card modules. The trouble is the changed kernel module file name due to module compression. The attached hack makes generate_soundcard_db.rb create a valid list.
Comment 2 Michal Filka 2020-05-05 09:27:00 UTC
(In reply to Libor Pechacek from comment #0)
> Created attachment 836454 [details]
> hack to make generate_soundcard_db.rb work again
> 
> The sound card database embedded into yast2-sound is empty on Tumbleweed. As
> a result, the "add new sound card" dialog does not offer any cards for
> addition. The root cause is a failed run of generate_soundcard_db.rb during
> package build, where the script fails to locate sound card modules. The
> trouble is the changed kernel module file name due to module compression.
> The attached hack makes generate_soundcard_db.rb create a valid list.

thanks for the patch. It should be in yast2-sound 4.2.5
Comment 3 Michal Filka 2020-05-06 08:17:24 UTC
Fixed in yast2-network 4.3.0
Comment 4 Ladislav Slezák 2020-05-06 08:27:03 UTC
> Fixed in yast2-network 4.3.0

Actually yast2-sound-4.3.0 ;-)

https://github.com/yast/yast-sound/pull/48