Bug 1170130 - Recovery mode: Need to confirm "allow vendor change" hundreds of times
Recovery mode: Need to confirm "allow vendor change" hundreds of times
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
All Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-22 04:14 UTC by Tony Pott
Modified: 2020-05-25 08:18 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Pott 2020-04-22 04:14:43 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0
Build Identifier: 

I have an existing installation of Tumbleweed, that I broke. Having failed to fix it using the recovery mode on the install disk, I performed an upgrade instead, forcing it back to a known state. This worked.
BUT. The experience was horrible.
Aside from the 4k display issue, the main, and I think obvious and fixable problem was that it wanted to switch repos on all my packages sourced from non-default repos back to the default: which is fine, I wanted to do just that. But the only way to do this was to click on the resolver option to allow the change  for EVERY SINGLE package: AND THEre WERE 100's. 
Really guys? You couldn't present me with a little dialog that allowed me to do all this with '--allow-vendor-change' set? It took me > 41 mins of doing nothing but click the mouse and scroll (I started timing a little way in). 
I've been using openSuse (and before that SuSE) since about 2002, and I have the greatest love for all you guys, so what did I do to you to make you hate me?


Reproducible: Always

Steps to Reproduce:
1. Have an installed system, with software from multiple repos.
2. Break it so I won't boot (some stupidity required here)
3. Fail to work out what is going on in recovery mode.
4. Perform upgrade from install disk to force the system into known state.
5. Resolve to eat own entrails before repeating the experience.
Actual Results:  
Working system, user has migraine

Expected Results:  
Working system, user happy
Comment 1 Stefan Hundhammer 2020-04-28 10:34:07 UTC
This is a situation where I would have tried this:

Upon the first dependency resolver problem, hit "Cancel" in that problem reporting dialog.

Open the package management dialog. Switch to the "Repositories" view.
Above the package list on the right side of the screen, there should now be a message "Switch system packages to this repository". Click on that hyperlink.

Not sure if this isn't even done automatically: Trigger a dependency resolver run with "check dependencies" from the menu.


Notice that I did not try this; I wrote this from memory. I didn't want to install a system, wreck it and then try the recovery mode to try this.
Comment 2 Stefan Hundhammer 2020-04-28 10:35:48 UTC
Can you describe in a bit more detail the steps you did in recovery mode?

It is very well possible that we really do have a problem there; but this is a scenario that is not at all easy to test, so more details would be very welcome.
Comment 4 Stefan Hundhammer 2020-05-25 08:18:43 UTC
This should now be fixed along with bug #1170521.

If you get into this situation, close the dependency problem window with "Cancel" and in the package selector window use "Allow vendor change" from the menu.

This is not that much different from the solution I suggested in comment #1, but it might be a bit more obvious.