Bug 1169794 - cryptsetup fails to prompt for password with latest TW snapshot
cryptsetup fails to prompt for password with latest TW snapshot
Status: RESOLVED DUPLICATE of bug 1169783
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-17 17:11 UTC by IT wrx
Modified: 2020-04-17 22:29 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description IT wrx 2020-04-17 17:11:33 UTC
I'm not sure what package might be the cause, maybe the recent plymouth upgrade and systemd-ask-password-plymouth.service? 

After updating to Tumbleweed snapshot 20200414 i can't get all the way to the login screen.

The cryptsetup/luks password prompt for a data drive (internal sata3
hdd with ext4) i have auto-mounting via fstab and crypttab is not being shown. I
tried booting the previous kernel with the same result. The outpout in runlevel 3 while booting showed "starting cryptography for $drive" but it just sat there shortly thereafter (there might have been a line or two of unrelated log output) until i got sick of waiting (many, many minutes).

Finally, using a previous snapshot (from 4-14-2020, i think?) allowed me
to enter my luks password for the data drive and finish booting. 

I'm still using this snapshot as i try to figure out how to mount the root partition/subvolume from this snapshot so i can modify fstab/cryptab so i can finish booting despite this aux drive not being decrypted. I'm new to openSUSE, btrfs, snapper. I'm coming from arch and ext4 and mounting and chroot were much simpler. :) Point being, i don't know how much help i'm going to be with this bug.

thanks
Comment 1 Antoine Belvire 2020-04-17 18:59:30 UTC
Most probably a dupe of 1169783.

*** This bug has been marked as a duplicate of bug 1169783 ***
Comment 2 andy great 2020-04-17 21:35:36 UTC
I found out that it is a plymouth bug, lock all plymouth package from upgrading and upgrade all the rest of the package, it should work now.
Comment 3 IT wrx 2020-04-17 22:29:41 UTC
thanks everybody.