Bug 1169509 - [Ruby2.7] swig fails to build against ruby 2.7
[Ruby2.7] swig fails to build against ruby 2.7
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Klaus Kämpf
E-mail List
:
Depends on:
Blocks: 1169435
  Show dependency treegraph
 
Reported: 2020-04-15 07:38 UTC by Dominique Leuenberger
Modified: 2020-04-17 08:41 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2020-04-15 07:38:11 UTC
openSUSE Tumbleweed is in progress of moving to Ruby 2.7

swig is amongst the packages failing to build in Staging:L

https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:L/swig/standard/x86_64
Comment 1 Klaus Kämpf 2020-04-15 10:18:54 UTC
https://build.opensuse.org/request/show/794144
Comment 2 Dominique Leuenberger 2020-04-17 08:35:56 UTC
(In reply to Klaus Kämpf from comment #1)
> https://build.opensuse.org/request/show/794144

Was forwarded and accepted to Factory - Staging:L rebased and retested:
swig still failing:

https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:L/swig/standard/x86_64
Comment 3 Dominique Leuenberger 2020-04-17 08:41:37 UTC
(In reply to Dominique Leuenberger from comment #2)
> (In reply to Klaus Kämpf from comment #1)
> > https://build.opensuse.org/request/show/794144
> 
> Was forwarded and accepted to Factory - Staging:L rebased and retested:
> swig still failing:

Hmm. despite :L being rebased it is apparently building an old branch; will retry that again (a local branch seems to be ok)