Bug 1169476 - systemd-networkd-wait-online fails with bridged interfaces
systemd-networkd-wait-online fails with bridged interfaces
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Basesystem
Leap 15.1
All All
: P5 - None : Major (vote)
: ---
Assigned To: systemd maintainers
E-mail List
https://github.com/systemd/systemd/is...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-14 20:17 UTC by pgnd _
Modified: 2021-09-14 05:24 UTC (History)
3 users (show)

See Also:
Found By: Community User
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pgnd _ 2020-04-14 20:17:18 UTC
on a server running,

	lsb_release -rd
		Description:    openSUSE Leap 15.1
		Release:        15.1

with 15.1's updated

	systemd-234-lp151.26.13.1.x86_64

with systemd-network set to manage network

	networkctl
		IDX LINK             TYPE               OPERATIONAL SETUP
		  1 lo               loopback           carrier     unmanaged
		  2 enp11s0          ether              carrier     configuring
		  3 br0              ether              routable    configured

		3 links listed.

where

	cat /etc/systemd/network/br0.netdev 
		[NetDev]
		Name=br0
		Kind=bridge

	cat /etc/systemd/network/br0.network
		[Match]
		Name=br0

		[Network]
		Address=10.0.0.10/24
		Gateway=10.0.0.1
		IPForward=1
		IPv6AcceptRA=0

	cat /etc/systemd/network/uplink.network
		[Match]
		Name=enp11s0

		[Network]
		Bridge=br0

if a systemd unit is created with a legitimate wait-online dependency on the bridge,

	cat /etc/systemd/system/some.service 
		[Unit]
		...

		[Service]
		...
		ExecStartPre=/usr/lib/systemd/systemd-networkd-wait-online --interface=br0
		ExecStart=...
		...

		[Install]
		WantedBy=multi-user.target

on boot, the 'systemd-networkd-wait-online.service' fails

	[  146.400104] systemd-networkd-wait-online[1381]: Event loop failed: Connection timed out
	[  146.420204] systemd[1]: systemd-networkd-wait-online.service: Main process exited, code=exited, status=1/FAILURE
	[  146.422071] systemd[1]: Failed to start Wait for Network to be Configured.
	[  146.422242] systemd[1]: systemd-networkd-wait-online.service: Unit entered failed state.
	[  146.422268] systemd[1]: systemd-networkd-wait-online.service: Failed with result 'exit-code'.

it's a known issue,

	systemd-networkd-wait-online fails with bridged interfaces
	 https://github.com/systemd/systemd/issues/2154

apparently fixed by bump to systemd version >= 242

	https://github.com/systemd/systemd/issues/2154#issuecomment-536214625
Comment 1 Franck Bui 2020-04-20 14:26:54 UTC
(In reply to pgnd _ from comment #0)
> it's a known issue,

I would call that a limitation instead ;)

As you already noticed this limitation has been removed in the last versions of systemd (since v242) but the version used by Leap 15.* is much older and thus systemd-networkd stuff doesn't support waiting for bridged interfaces.

Backporting this feature is not trivial and is not planned for the time being especially since networkd is not the default network manager used by Leap/SLE distros, sorry.

Hope that make sense.
Comment 3 pgnd _ 2020-04-20 15:37:15 UTC
The 'doesn't work with bridges' is a mising feature, not a bug?

It renders the system -- using a 'feature' that's documented as avaiable in the release's officially supported version of systemd -- broken, and firing errors.

I'll disagree that's not a bug.

Option to backport exists, though apparently not trivial as you say.

Option to bump systemd version -- for this and many other reasons -- exists as well.

Iiuc, 15.2 is locked at the same systemd version as 15.1 -- so we can expect it'll be missing this "feature" as well, for its entire life cycle?
Comment 4 Franck Bui 2020-04-20 16:16:29 UTC
I understand that's not ideal but please understand that we can't afford to backport a feature each time an openSUSE user is missing one.

Nevertheless since Leap is open source you could try to contribute and backport the missing feature but from now on I'm afraid that we won't work on it.

Sorry.
Comment 5 Dr. Werner Fink 2020-04-20 16:31:59 UTC
NO need to read this bugzilla twice
Comment 6 pgnd _ 2020-04-20 17:00:47 UTC
> we can't afford to backport a feature each time an openSUSE user is missing one

srsly?  THAT's your response?

Easy fix -- we won't report.

The 'contribution' starts with trying to have a conversation -- difficult to do when you trivialize/dismiss the need, call brokenness a 'feature', and close the bug, isn't it?.

( Have you been _reading_ the concerns folks are expressing re: Jump ... ? )

so, sounds like you 'can't afford' to make sure 15.2 will work properly re: this brokenness.

Ok, not my decision, clearly.

in any case, the fix is easy.  Use another distro -- we've got plenty.

shame.
Comment 7 Episteme PROMENEUR 2021-09-14 05:24:41 UTC
Same problem here.

NetworkManager-wait-online.service: Main process exited, code=exited, status=1/FAILURE

openSUSE Argon 15.3
systemd 246.15

Conséquences:

randomly several apps fails to start when opening a kde session.

- duo web app
- facebook web app
- google messages web app
- qemu VM
- skypeforlinux
- weather applet

If I start manually the service, then it starts with success.

Perhaps adding a restart on fail would solves the problem. No ?

I dont' know the systemd langage.

may someone supply to me the good sequence of statements to add ?

thanks