Bug 1169316 - Sensors_detect loads wrong driver for Nuvoton W83677HG-I (NCT5572D/NCT6771F/NCT6772F/NCT6775F) Super IO Sensors
Sensors_detect loads wrong driver for Nuvoton W83677HG-I (NCT5572D/NCT6771F/N...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Jean Delvare
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-13 16:03 UTC by Stuart Rogers
Modified: 2020-05-15 07:47 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
sensors_detect output to show the issue (8.77 KB, text/plain)
2020-04-13 16:03 UTC, Stuart Rogers
Details
output from run using fixes (5.92 KB, text/plain)
2020-05-12 08:15 UTC, Stuart Rogers
Details
output from successful test (5.76 KB, text/plain)
2020-05-12 10:40 UTC, Stuart Rogers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stuart Rogers 2020-04-13 16:03:57 UTC
Created attachment 835546 [details]
sensors_detect output to show the issue

Running sensors_detect on my system specifies the driver for Nuvoton W83677HG-I (NCT5572D/NCT6771F/NCT6772F/NCT6775F) as w83627ehf however this does not show any sensors when running sensors -u. Manually changing to NCT6775 in /etc/sysconfig/lm_sensors then allows sensors -u to display the valid sensors. I will attach a copy of the sensors_detect run, this is 100% reproducible. This issue has happened in the past few weeks as originally sensors_detect worked without intervention when I first installed Tumbleweed but I am unable to identify exactly when this happened.
Comment 1 Takashi Iwai 2020-04-14 13:07:44 UTC
Jean, can you check this issue?
Comment 2 Jean Delvare 2020-05-07 12:40:16 UTC
Sorry, missed that one.

Historically, support for the Nuvoton W83677HG-I and derivative was first added to the w83627ehf driver, so that's the driver recommended by sensors-detect. Later, support for the same device was also added to the nct6775 driver. In kernel v5.6, support was removed from the w83627ehf driver to avoid maintaining duplicate code, however sensors-detect was not updated accordingly, so it is now pointing to the wrong driver.

I guess your problem appeared when you updated to kernel v5.6.

I will submit a fix upstream, and will also patch our sensors package. Thanks for the reporting the problem.
Comment 3 Jean Delvare 2020-05-07 14:03:31 UTC
Candidate fix committed, can you please test the package from:

https://build.opensuse.org/package/binaries/Base:System/sensors/openSUSE_Factory

and report if sensors-detect now points to the correct driver (nct6775)?
Comment 4 Stuart Rogers 2020-05-12 08:15:40 UTC
Created attachment 837659 [details]
output from run using fixes

The fixes were installed but did not fix the issue as the run failed as shown here.
Comment 5 Jean Delvare 2020-05-12 09:30:36 UTC
Thanks for the quick testing and sorry for getting it wrong. I missed half of the changes, as I used a mechanism which was only supported for I2C-based sensors and not Super-I/O-based ones.

A new test version is ready now, same location. Please make sure that the package version is >= 3.6.0-131.1.
Comment 6 Stuart Rogers 2020-05-12 10:40:24 UTC
Created attachment 837665 [details]
output  from successful test

New set of fixes worked fine as shown here.
Comment 7 Jean Delvare 2020-05-12 14:17:44 UTC
Great, thanks for testing. I'll submit the fix upstream and push it to Factory as well.
Comment 8 OBSbugzilla Bot 2020-05-12 15:10:07 UTC
This is an autogenerated message for OBS integration:
This bug (1169316) was mentioned in
https://build.opensuse.org/request/show/803015 Factory / sensors
Comment 9 Jean Delvare 2020-05-15 07:47:38 UTC
Fixed in Factory, closing.