Bug 1169137 - process '/usr/sbin/grub2-probe' started with executable stack
process '/usr/sbin/grub2-probe' started with executable stack
Status: RESOLVED FIXED
: 1168869 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
aarch64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Michael Chang
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-09 17:10 UTC by Andreas Schwab
Modified: 2021-09-23 18:45 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schwab 2020-04-09 17:10:56 UTC
# rpm -qf /usr/sbin/grub2-probe
grub2-2.04-7.1.aarch64
# readelf -Wl /usr/sbin/grub2-probe | grep GNU_STACK
  GNU_STACK      0x000000 0x0000000000000000 0x0000000000000000 0x000000 0x000000 RWE 0x10
Comment 1 Michael Chang 2020-04-16 14:44:50 UTC
I have identified that one of our patch has closure. The executable stack is caused by function trampoline constructed on stack to support closure semantics. My preliminary testing with that closure removed really can turn the stack into non-executable so that I'm working on a fix to replace closure with other means to achieve the same thing.
Comment 2 Michael Chang 2020-04-17 13:48:12 UTC
The SR forwarded to openSUSE:Factory

https://build.opensuse.org/request/show/794918

Change the resolution to fixed.
Comment 3 Michael Chang 2020-04-17 13:51:30 UTC
*** Bug 1168869 has been marked as a duplicate of this bug. ***