Bug 1169132 - [ARMv7] gcc 9 miscompiles Leap 15.1 kernel
[ARMv7] gcc 9 miscompiles Leap 15.1 kernel
Status: RESOLVED DUPLICATE of bug 1169156
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
armv7 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-09 16:32 UTC by Michal Suchanek
Modified: 2020-04-09 23:09 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
archive of preprocessed sources, assembly files, and gcc commands used (1.68 MB, application/x-compressed-tar)
2020-04-09 16:32 UTC, Michal Suchanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Suchanek 2020-04-09 16:32:33 UTC
Created attachment 835378 [details]
archive of preprocessed sources, assembly files, and gcc commands used

When current SLE15 SP1 tip is merged into openSUSE 15.1 kernel branch the build fails on armv7 because of references to 64bit integer division helpers that the kernel does not provide.

ERROR: "__aeabi_uldivmod" [fs/btrfs/btrfs.ko] undefined!                                                                                                                           
scripts/Makefile.modpost:94: recipe for target '__modpost' failed                                                                                                                  

Technically we should be building the kernel with gcc 7 which does not have this bug but there is a bug in selecting the gcc for armv7 builds.
Comment 1 Petr Tesařík 2020-04-09 23:09:48 UTC
Oh, this is in fact the same bug that I have meanwhile analyzed in more depth.

*** This bug has been marked as a duplicate of bug 1169156 ***