Bug 1168886 - [Build 20200402] openQA test sometimes fails in welcome: "Package none is not available"
[Build 20200402] openQA test sometimes fails in welcome: "Package none is not...
Status: RESOLVED DUPLICATE of bug 1151187
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/bPBf7dPT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-07 14:47 UTC by Michel Normand
Modified: 2020-04-08 13:30 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
y2log.txt (3.09 MB, text/plain)
2020-04-07 14:47 UTC, Michel Normand
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Normand 2020-04-07 14:47:20 UTC
Created attachment 835110 [details]
y2log.txt

[Build 20200402] openQA test fails in welcome "Package none is not available"

## Observation

This is a transient failure during openQA test, that disapear if same test manually retried.
When failure following lines identified in y2log:
=== extract y2log
[Ruby] packages/common.rb:124 Asking for packages: ["none"]
[Ruby] lib/cheetah.rb:160 Executing "/usr/bin/rpm -q --whatprovides none".
[Ruby] lib/cheetah.rb:208 Standard output: no package provides none
[Ruby] lib/cheetah.rb:180 Status: 1
[Ruby] modules/PackageSystem.rb:354 Query installed package with '/usr/bin/rpm -q --whatprovides none' and result no package provides none
[Ruby] packages/common.rb:128 Remaining packages: ["none"]
[Ruby] binary/Yast.cc(ycp_module_call_ycp_function):282 Dynamic Proxy: [UI::OpenDialog] with [6] params
[Ruby] binary/Yast.cc(ycp_module_call_ycp_function):291 Namespace created from UI
[ui] YUINamespace.cc(createFunctionCall):1035 overloaded OpenDialog, 2@12
[Ruby] binary/Yast.cc(ycp_module_call_ycp_function):326 Call OpenDialog
[Ruby] binary/Yast.cc(ycp_module_call_ycp_function):332 Append parameter `opt (`decorated)
[Ruby] binary/Yast.cc(ycp_module_call_ycp_function):332 Append parameter `HBox (`VSpacing (10), `VBox (`HSpacing (40), `Empty (), `VSpacing (0.2), `RichText ("These packages need to be installed:<p>none<br>"), `ButtonBox (`PushButton (`id (`ok), `opt (`default, `key_F10, `okButton), "&Install"), `PushButton (`id (`cancel), `opt (`key_F9), "&Cancel"))))
===

openQA test in scenario opensuse-Tumbleweed-DVD-ppc64le-gpt@ppc64le fails in
[welcome](https://openqa.opensuse.org/tests/1226074/modules/welcome/steps/8)

## Test suite description



## Reproducible

Fails since (at least) Build [20200402](https://openqa.opensuse.org/tests/1226074) (current job)


## Expected result

Last good: [20200329](https://openqa.opensuse.org/tests/1219230) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=ppc64le&distri=opensuse&flavor=DVD&machine=ppc64le&test=gpt&version=Tumbleweed)
Comment 1 Martin Vidner 2020-04-07 19:09:41 UTC
Thanks for the report!

Debugging notes:

The "none" comes from
https://github.com/yast/yast-yast2/blob/90d517f3dd30fe967044a06a4178e58243eca9c1/library/packages/src/modules/PackageSystem.rb#L492

The code in PackageSystem.InstallKernel is rather old. AFAICT (part of) its intent is to
1. check whether a kernel is installed already
2. if not, initialize the repositories and look there

This bug happens because (1) is coded in a weird way and returns a ["none"] list of packages instead of an empty list [], AND (2) does not find any repos.

2020-04-06 22:29:14 <1> install(2946) [Pkg] Package.cc(PkgQueryProvides):123 Searching packages providing: kernel
2020-04-06 22:29:14 <1> install(2946) [Ruby] modules/PackageSystem.rb:483 provides: []
2020-04-06 22:29:14 <3> install(2946) [Ruby] modules/PackageSystem.rb:490 not exactly one package provides tag kernel
...
2020-04-06 22:29:14 <2> install(2946) [Ruby] modules/PackageSystem.rb:116 No package repository available
2020-04-06 22:29:14 <0> install(2946) [Ruby] packages/common.rb:124 Asking for packages: ["none"]
Comment 2 Martin Vidner 2020-04-08 13:30:46 UTC
Ah, there are several duplicates already.

*** This bug has been marked as a duplicate of bug 1151187 ***