Bug 1168817 - NVIDIA G04 needs kernel 5.6 patch
NVIDIA G04 needs kernel 5.6 patch
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 3rd Party Driver
Current
Other Other
: P3 - Medium : Major (vote)
: ---
Assigned To: Stefan Dirsch
Stefan Dirsch
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-07 06:53 UTC by Philip Raets
Modified: 2020-04-10 18:09 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Raets 2020-04-07 06:53:40 UTC
While nvidia G05 has been repackaged with the kernel 5.6 patch, the G04 are not.

Is it possible to do this?

Thanks,

Philip
Comment 1 Stefan Dirsch 2020-04-07 09:41:10 UTC
I already contacted NVIDIA about this.
Comment 2 Philip Raets 2020-04-10 12:46:20 UTC
Any update on this?

Now I've installed a patched version of the installer, but would like to go back to the rpm version.

patches:
kernel 5.5: https://gitlab.com/snippets/1943814
kernel 5.6: https://gitlab.com/snippets/1943873

patched installer: https://www.dropbox.com/s/r9cn66odzn8fee5/NVIDIA-Linux-x86_64-390.132.run?dl=0
Comment 3 Stefan Dirsch 2020-04-10 12:51:11 UTC
Unfortunately not. I haven't heard back from them.
Comment 4 Stephan Hemeier 2020-04-10 13:20:06 UTC
Arch Linux has also a patch for kernel 5.6:
https://aur.archlinux.org/packages/nvidia-390xx-dkms/
Comment 5 Stefan Dirsch 2020-04-10 18:09:37 UTC
Ok. I've added both patches. The repository should be updated early next week after public holidays.

  nvidia-gfxG04-kmp-default-390.132_k5.6.2_1-14.1.x86_64.rpm

# rpm ---changelog -q  nvidia-gfxG04-kmp-default
* Fr Apr 10 2020 Stefan Dirsch <sndirsch@suse.com>
- add patch kernel-5.6.patch to fix build with kernel 5.6
  (boo#1168817)
[...]