Bug 1168655 - Corrupted graphics.
Corrupted graphics.
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-05 07:38 UTC by Adam Szyszko
Modified: 2020-04-20 08:03 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (szyszko.86)


Attachments
Picture of konsolewith blur. (1023.49 KB, image/jpeg)
2020-04-05 07:38 UTC, Adam Szyszko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Szyszko 2020-04-05 07:38:22 UTC
Created attachment 834886 [details]
Picture of konsolewith blur.

After kernel update to 5.6 all graphics are corrupted like in topography map. I'm using default graphics configuration with no tweaks. This is visible especially on KDE's blur or wallpapers with fading colors. 

inxi -Gxx:

Graphics:  Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
           Display: x11 server: X.Org 1.20.7 driver: modesetting unloaded: fbdev,vesa alternate: intel compositor: kwin_x11 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.2 compat-v: 3.0 direct render: Yes
Comment 1 Takashi Iwai 2020-04-05 07:58:46 UTC
Which kernel did you test?  If it's 5.6.0, it has a known regression wrt i915 graphics and has been fixed in 5.6.2 kernel package including the backport fix patch.

If it still shows the problem, please report to the upstream, the issue on gitlab.freedesktop.org.
Comment 2 Adam Szyszko 2020-04-05 08:07:51 UTC
I've tested only 5.6.0, hen reverted to 5.5.13. I'll check 5.6.2 and report if problem exists. Thank You.
Comment 3 Adam Szyszko 2020-04-06 09:47:04 UTC
I have managed to install kernel 5.6.2 from kernel:HEAD to test if my problem still exist and it seems that everything is fine.
Comment 4 Jiri Slaby 2020-04-06 10:27:04 UTC
Great, thanks for confirmation.
Comment 5 Adam Szyszko 2020-04-09 06:58:04 UTC
Until today I was on 5.5.13, waiting for official update to 5.6.2. After updating to 20200407 kernel 5.6.2 arrived and my bug is still persistent. What was the difference between kernel:HEAD and official release? Why this bug is appearing again?
Comment 6 Adam Szyszko 2020-04-09 17:53:08 UTC
Problem occurs again after official update to 20200407
Comment 7 Adam Szyszko 2020-04-10 06:35:34 UTC
Again, I tried kernel 5.6.2-3.1 from kernel:HEAD and when using it everything is ok. What's the difference between them apart being up to date?
Comment 8 Takashi Iwai 2020-04-10 08:21:27 UTC
Hm werid.  Could you try also the kernel in OBS Kernel:stable, too?

Basically both Kernel:HEAD and Kernel:stable and TW kernels should be equivalent at this moment.  Kernel:HEAD will start tracking the new -rc upstream kernel once after rc1 is released, but until then both are merged together.

And Kernel:stable is the develproject of TW kernel, i.e. it's the source.  It might be newer than the currently released TW kernel, but if Kernel:stable works, TW kernel should work later, too.
Comment 9 Adam Szyszko 2020-04-10 08:36:06 UTC
That's what I thought. I'll try OBS later in the evening.
Comment 10 Adam Szyszko 2020-04-10 17:41:01 UTC
So, I'm currently on OBS stable repo with 5.6.3-2.g5b340fd-default kernel and everything is ok. 
What I discovered during kernel swapping is that whenever I install a new kernel from external repos, there is a bunch of kernel-firmware-* files, including i915 module. I can't remember when there was such update from original TW repo.
Comment 11 Adam Szyszko 2020-04-11 06:40:23 UTC
Which repo provides default kernel image for TW?
Comment 12 Adam Szyszko 2020-04-11 07:23:15 UTC
Unintentionally I found a stupid workaround. When I close lid and open it again everything is back to normal...
Comment 13 Takashi Iwai 2020-04-11 09:59:11 UTC
(In reply to Adam Szyszko from comment #11)
> Which repo provides default kernel image for TW?

http://download.opensuse.org/tumbleweed/
Comment 14 Takashi Iwai 2020-04-11 10:00:40 UTC
If the current OBS Kernel:stable works, then it must be OK.
Please report back if the official TW kernel later still doesn't work.

The update of kernel-firmware-* was performed just because of either the package version or release numbers are higher in the develproject.  They are likely irrelevant and you can take back to TW version.
Comment 15 Adam Szyszko 2020-04-11 11:10:42 UTC
Thank you for your effort. I'll stick to official update cycle and live with close-open lid for some time. I'll report if anything change. 

I even tried to back to official release of KDE because I thought it might be KDE repository relevant but with no luck. 

So, for now, I wish you a happy Easter, and thank you very much again.
Comment 16 Adam Szyszko 2020-04-19 09:19:37 UTC
Update to 5.6.4 fixed my problem. Job done.
Comment 17 Jiri Slaby 2020-04-20 08:03:41 UTC
.