Bug 1168383 - kernel 5.6: baytrail hdmi audio not working
kernel 5.6: baytrail hdmi audio not working
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-01 22:48 UTC by Giacomo Comes
Modified: 2020-04-04 16:36 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giacomo Comes 2020-04-01 22:48:58 UTC
On my Intel Compute Stick STCK1 (baytrail hdmi audio) 
sound is not working with the kernel 5.6

It doesn't seem an alsa issue. The output of alsa-info.sh is essentially the same when booting 5.5 or 5.6.

I have bisected the kernel and I found the commit that introduced the issue:

commit 58d124ea2739e1440ddd743d46c470fe724aca9a
Author: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
Date:   Thu Oct 31 12:26:04 2019 +0100

    drm/i915: Complete crtc hw/uapi split, v6.
    
    Now that we separated everything into uapi and hw, it's
    time to make the split definitive. Remove the union and
    make a copy of the hw state on modeset and fastset.
    
    Color blobs are copied in crtc atomic_check(), right
    before color management is checked.

I'm contacting intel-gfx to let them know about the problem.
Comment 1 Takashi Iwai 2020-04-02 08:01:01 UTC
Thanks for the report.  Let me know (or give the upstream bug URL) if you get a feedback from upstream.
Comment 2 Manfred Hollstein 2020-04-02 08:46:10 UTC
I'm not sure if what I am seeing since 5.6 is related to this, but my setup here (Linux PC with Intel graphics connected via HDMI to an AVR) shows the same/similar symptoms. On a kernel before 5.6, Kodi shows the following as its audio output device "HDA Intel PCH, DON DENON-AVR on DisplayPort #2" and happily plays back audio, while with 5.6.1 it simply shows this: "HDA Intel PCH, HDMI #2" not producing any sound. Interestingly without the AVR in between, but with a direct connection via HDMI to the TV, it works.
Comment 3 Giacomo Comes 2020-04-02 14:58:43 UTC
Already fixed upstream. Here is the conversation I had on intel-gfx:

>> Should hopefully be fixed with
>> commit 2bdd4c28baff ("drm/i915/display: Fix mode private_flags
>> comparison at atomic_check")
>> 
>> Stable folks, please pick that up for 5.6.x stable releases.
>
>I can confirm that the commit indeed solves the problem I have.
>It should go in the stable 5.6.x release ASAP.

Hopefully the fix should land in the stable tree very soon.
When it happens, I'll close this bug.
Comment 4 Takashi Iwai 2020-04-02 15:07:38 UTC
Thanks!  I pushed the commit to my master/for-next branch, so that it'll be merged even before the next stable update.
Comment 5 Takashi Iwai 2020-04-03 16:24:06 UTC
Now it's going to TW.  Let's close.

Manfred, if your problem persists with the latest kernel package in OBS Kernel:HEAD or Kernel:stable repo, it's likely a different problem.  If so, please open another bug report.  Thanks.
Comment 6 Manfred Hollstein 2020-04-04 16:36:42 UTC
(In reply to Takashi Iwai from comment #5)
> Now it's going to TW.  Let's close.
> 
> Manfred, if your problem persists with the latest kernel package in OBS
> Kernel:HEAD or Kernel:stable repo, it's likely a different problem.  If so,
> please open another bug report.  Thanks.

Just to report back, it's working for me, too. This is the latest kernel from Kernel:stable, and HDMI via AVR works again:

$ rpm -q kernel-default-5.6.2-2.1.g7f2ce15.x86_64 --changelog
* Thu Apr 02 2020 tiwai@suse.de
- drm/i915/display: Fix mode private_flags comparison at
  atomic_check (bsc#1168383).
- commit a83dd8f

Thanks a lot!