Bug 1168371 - [Build 20200331] openQA test fails in vagrant/sshfs
[Build 20200331] openQA test fails in vagrant/sshfs
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Virtualization:Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dan Čermák
E-mail List
https://openqa.opensuse.org/tests/122...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-01 19:54 UTC by Dominique Leuenberger
Modified: 2020-04-02 07:24 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2020-04-01 19:54:14 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_vagrant@64bit fails in
[sshfs](https://openqa.opensuse.org/tests/1221271/modules/sshfs/steps/39)

## Test suite description
Maintainer: dancermak. Test vagrant, vagrant plugins and the vagrant boxes


## Reproducible

Fails since (at least) Build [20200110](https://openqa.opensuse.org/tests/1141522)


## Expected result

Last good: (unknown) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=extra_tests_vagrant&version=Tumbleweed)
Comment 1 Dan Čermák 2020-04-01 20:52:06 UTC
This is caused by the implicit assumption of the testsuite that /sbin/ is a symlink to /usr/sbin. I have patched the testsuite to use /var/run -> /run instead.

Should be fixed by: https://build.opensuse.org/request/show/790711
Comment 2 Dan Čermák 2020-04-02 07:24:46 UTC
This should be fixed now as https://build.opensuse.org/request/show/790711 got accepted into Factory.