Bug 1168341 - [Build 20200331] openQA test fails in await_install: mkinitrd fails on i586
[Build 20200331] openQA test fails in await_install: mkinitrd fails on i586
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
i586 Other
: P5 - None : Critical (vote)
: ---
Assigned To: dracut maintainers
E-mail List
https://openqa.opensuse.org/tests/122...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-01 14:31 UTC by Fabian Vogt
Modified: 2021-11-08 16:35 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2020-04-01 14:31:51 UTC
aaa_base's get_kernel_version was fixed for .xz images, instead of failing it returns the proper kernel version now.

On i586 this breaks mkinitrd though. For i586, it currently uses the "vmlinu." regex for getting the kernel binaries in /boot, which also matches /boot/vmlinux-...-....xz, which isn't the bootable kernel. Until now, those were ignored because get_kernel_version failed.

Now that get_kernel_version is fixed, it now tries to build an initrd for the ".xz" versions, which obviously fails.

The fix is simple: Use i?86|x86_64) as match instead of i386|x86_64) in line 174.

## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-i586-textmode@32bit fails in
[await_install](https://openqa.opensuse.org/tests/1221153/modules/await_install/steps/11)

## Test suite description
Maintainer: okurz

Installation in textmode and selecting the textmode "desktop" during installation.


## Reproducible

Fails since (at least) Build [20200330](https://openqa.opensuse.org/tests/1219967)


## Expected result

Last good: [20200329](https://openqa.opensuse.org/tests/1218352) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=i586&distri=opensuse&flavor=DVD&machine=32bit&test=textmode&version=Tumbleweed)
Comment 1 Daniel Molkentin 2020-04-07 10:34:31 UTC
Fixed and submitted. Thanks.
Comment 2 Swamp Workflow Management 2020-04-07 11:10:08 UTC
This is an autogenerated message for OBS integration:
This bug (1168341) was mentioned in
https://build.opensuse.org/request/show/791954 Factory / dracut