Bug 1167654 - [Build20200322] nfs.rb failed with 'undefined method `[]=' for nil:NilClass' (NoMethodError)
[Build20200322] nfs.rb failed with 'undefined method `[]=' for nil:NilClass' ...
Status: RESOLVED DUPLICATE of bug 1166285
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-03-25 12:41 UTC by Jonathan Rivrain
Modified: 2020-03-25 12:52 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
y2logs (8.55 MB, application/x-xz)
2020-03-25 12:41 UTC, Jonathan Rivrain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Rivrain 2020-03-25 12:41:59 UTC
Created attachment 833836 [details]
y2logs

When pressing "cancel" after trying to add some nfs share, we get this :

2020-03-25 08:22:58 <3> susetest(5447) [Ruby] yast/wfm.rb:253 Client /usr/share/YaST2/clients/nfs.rb failed with 'undefined method `[]=' for nil:NilClass' (NoMethodError).
Backtrace:
/usr/share/YaST2/include/nfs/ui.rb:481:in `GetFstabEntry'
/usr/share/YaST2/include/nfs/ui.rb:613:in `HandleEvent'
/usr/share/YaST2/include/nfs/ui.rb:707:in `block in FstabDialog'
/usr/share/YaST2/include/nfs/ui.rb:697:in `loop'
/usr/share/YaST2/include/nfs/ui.rb:697:in `FstabDialog'
/usr/share/YaST2/include/nfs/wizards.rb:22:in `MainSequence'
/usr/share/YaST2/include/nfs/wizards.rb:30:in `block in NfsSequence'
/usr/lib64/ruby/vendor_ruby/2.6.0/yast/builtins.rb:546:in `eval'
/usr/share/YaST2/modules/Sequencer.rb:249:in `WS_run'
/usr/share/YaST2/modules/Sequencer.rb:320:in `block in Run'
/usr/share/YaST2/modules/Sequencer.rb:312:in `loop'
/usr/share/YaST2/modules/Sequencer.rb:312:in `Run'
/usr/share/YaST2/include/nfs/wizards.rb:44:in `NfsSequence'
/usr/lib64/ruby/vendor_ruby/2.6.0/yast/fun_ref.rb:33:in `call'
/usr/lib64/ruby/vendor_ruby/2.6.0/yast/fun_ref.rb:33:in `call'
/usr/share/YaST2/modules/CommandLine.rb:1556:in `Run'
/usr/share/YaST2/clients/nfs.rb:122:in `main'
/usr/share/YaST2/clients/nfs.rb:349:in `<top (required)>'
/usr/lib64/ruby/vendor_ruby/2.6.0/yast/wfm.rb:318:in `eval'
/usr/lib64/ruby/vendor_ruby/2.6.0/yast/wfm.rb:318:in `run_client'
/usr/lib64/ruby/vendor_ruby/2.6.0/yast/wfm.rb:206:in `call_builtin'
/usr/lib64/ruby/vendor_ruby/2.6.0/yast/wfm.rb:206:in `call_builtin_wrapper'
/usr/lib64/ruby/vendor_ruby/2.6.0/yast/wfm.rb:195:in `CallFunction'
/usr/lib/YaST2/bin/y2start:60:in `<main>'

See full logs attached.
Comment 1 Martin Vidner 2020-03-25 12:52:21 UTC
Thanks for the report!

This is a duplicate report, I will ask for increasing the priority for the fix.

*** This bug has been marked as a duplicate of bug 1166285 ***