Bug 1164926 - Installer rejects existing LVM on top of MDRAID
Installer rejects existing LVM on top of MDRAID
Status: RESOLVED DUPLICATE of bug 1136641
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Installation
Leap 15.1
All openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-02-26 05:24 UTC by Anton Samsonov
Modified: 2020-02-26 12:00 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Installation (upgrade) logs (60.18 KB, application/x-xz)
2020-02-26 05:24 UTC, Anton Samsonov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Samsonov 2020-02-26 05:24:53 UTC
Created attachment 831191 [details]
Installation (upgrade) logs

Steps to reproduce:

1. Install openSUSE 15.0 (or any previous version) as following:

* sda1 | sdb1 = /boot
* sda2 & sdb2 = mdraid = lvm physical volume
* lvm physical volume -> lvm volume group -> lvm logical volume = / (root)

2. Run openSUSE 15.1 installer in upgrade mode.

Expected result: installer is able to discover both mdraid and lvm.

Actual result: installer considers "some" physical volumes as "missing".

> The volume group /dev/vgTest is incomplete because some physical volumes
> are missing. Incomplete volume groups are not visible in the Partitioner
> and will be deleted at the final step, when all the changes are performed
> in the system.

At the same time, not only the installed system continues full operation,
the installer environment, when inspected manually, appears to function
properly and even activates lvm volumes automatically on top of all mdraids.

Long story short, my setup successfully underwent each upgrade from Leap 42.1
to Leap 15.0, but is suddenly rejected by Leap 15.1 installer. As my actual
configuration is comprised of 2 mdraid arrays, 2 lvm volume groups, each with
a dozen of logical volumes, I am attaching installation logs from much more
simple virtual setup with a single array, a single vg and a single lv.
Comment 1 Ancor Gonzalez Sosa 2020-02-26 12:00:40 UTC
The problem is not in the installer, but in a buggy release of the LVM tools that, unfortunately, slipped into 15.1. It was reported as bug#1136641 (and then several more times).

So this is just another duplicate of that. Marking it as so.

*** This bug has been marked as a duplicate of bug 1136641 ***