Bug 1164073 - Plymouth textmode splash causes broken colors in terminal
Plymouth textmode splash causes broken colors in terminal
Status: RESOLVED DUPLICATE of bug 1162535
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Basesystem
Leap 15.2
aarch64 Other
: P1 - Urgent : Normal (vote)
: ---
Assigned To: Cliff Zhao
E-mail List
:
Depends on:
Blocks: 1175965
  Show dependency treegraph
 
Reported: 2020-02-18 09:24 UTC by Guillaume GARDET
Modified: 2020-08-31 13:29 UTC (History)
7 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume GARDET 2020-02-18 09:24:30 UTC
Plymouth is broken on aarch64 openQA tests on textmode and GNOME:
* Textmode: https://openqa.opensuse.org/tests/1177011#step/first_boot/3
* GNOME: https://openqa.opensuse.org/tests/1176995#step/first_boot/11

If I disable plymouth, login prompt/screen look fine:
* textmode: https://openqa.opensuse.org/tests/1177758
* GNOME: https://openqa.opensuse.org/tests/1177801#step/first_boot/3

I suspect the branding packages which have been updated recently.
Comment 1 Guillaume GARDET 2020-02-18 13:21:34 UTC
The color palette restore seems to be broken. Maybe because of multiple fallbacks?

Anyway, setting plymouth theme to bgrt manually "fixed" the problem (tested on textmode).
Comment 2 Cliff Zhao 2020-02-20 06:19:21 UTC
Could this bug be closed as duplicated with "Bug 1162535 - Update openSUSE Plymouth theme for 15.2 to bgrt"? 
because mainly discussions are on that bug. and the root cause is the same between these 2 issues. Any objection?
Comment 3 Guillaume GARDET 2020-02-20 07:02:48 UTC
(In reply to Cliff Zhao from comment #2)
> Could this bug be closed as duplicated with "Bug 1162535 - Update openSUSE
> Plymouth theme for 15.2 to bgrt"? 
> because mainly discussions are on that bug. and the root cause is the same
> between these 2 issues. Any objection?

Ok, closing as duplicate.

*** This bug has been marked as a duplicate of bug 1162535 ***
Comment 4 Fabian Vogt 2020-02-26 11:01:30 UTC
(In reply to Guillaume GARDET from comment #1)
> The color palette restore seems to be broken. Maybe because of multiple
> fallbacks?

^ should be fixed independently, so I'm reopening this report for that.
Comment 5 Cliff Zhao 2020-02-26 12:01:55 UTC
(In reply to Fabian Vogt from comment #4)
> (In reply to Guillaume GARDET from comment #1)
> > The color palette restore seems to be broken. Maybe because of multiple
> > fallbacks?
> 
> ^ should be fixed independently, so I'm reopening this report for that.

Insufficient
Comment 6 Lubos Kocman 2020-06-03 08:15:04 UTC
Changing priority to P2
Comment 7 Cliff Zhao 2020-06-19 16:13:48 UTC
(In reply to Guillaume GARDET from comment #3)
> (In reply to Cliff Zhao from comment #2)
> > Could this bug be closed as duplicated with "Bug 1162535 - Update openSUSE
> > Plymouth theme for 15.2 to bgrt"? 
> > because mainly discussions are on that bug. and the root cause is the same
> > between these 2 issues. Any objection?
> 
> Ok, closing as duplicate.
> 
> *** This bug has been marked as a duplicate of bug 1162535 ***

*** This bug has been marked as a duplicate of bug 1162535 ***