Bug 1161733 - Ethernet connection through Network Manager disconnects irregularly
Ethernet connection through Network Manager disconnects irregularly
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-23 22:05 UTC by Petr Matula
Modified: 2020-02-03 15:20 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
hwinfo (836.02 KB, text/plain)
2020-01-29 22:33 UTC, Petr Matula
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Matula 2020-01-23 22:05:50 UTC
Ethernet connection through Network Manager disconnects irregularly on my laptop Dell Latitude E6430. Sometimes in short interval e.g 1 second. It's probably connected with kernel. I've got this problem on kernels 5.x.x.
Connection is without problem on kernels 4.x.x
Comment 1 Takashi Iwai 2020-01-29 16:24:54 UTC
Could you confirm that it's really a kernel regression?
e.g. you can install the old openSUSE Leap 15.1 kernel on your machine and see whether the problem doesn't occur, at least.

Also, there are a collection of kernel packages in my OBS repo, e.g. OBS home:tiwai:kernel:4.9 contains the latest 4.9 TW kernel.  Narrowing down the regression range by trying those package would be greatly appreciated.

Last but not least, please give hwinfo output.
Comment 2 Petr Matula 2020-01-29 22:15:53 UTC
I've got kernel 4.16.10-1. It's OK.
Kernel 5.4.14-1 it' not OK (other kernels 5.4.x are problematic too).
I use kernel 5.5.0-2g7felf4 from KOTD right now and this kernel is without problem.
Comment 3 Petr Matula 2020-01-29 22:33:27 UTC
Created attachment 828598 [details]
hwinfo
Comment 4 Takashi Iwai 2020-02-03 15:20:28 UTC
OK, thanks.  Since TW kernel already moved 5.5, let's close now by assuming 5.5 works fine.

Feel free to reopen if you encounter the issue again on 5.5.y kernel.